the required fields aren't working