What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    "revision history" is not coming up when I click "more"

    Asked by macssam on July 11, 2014 at 06:51 AM
    "revision history" is not coming up when I click "more"
  • Profile Image
    JotForm Founder

    Answered by aytekin on July 11, 2014 at 06:52 AM

    I just tried this and I didn't get any error. Are you saying when you click on "More" you see a list of options but you do not see a "Revision History" option?

    Here is what I see when I click on More:

  • Profile Image

    Answered by macssam on July 11, 2014 at 09:46 AM

    the form has disappeared from the main menu

    it's suddenly in the archive

    do I have to embed the iFrame code every time I make a change ...
  • Profile Image
    JotForm Support

    Answered by EltonCris on July 11, 2014 at 10:31 AM

    @macssam

    I'm not sure if that relates to your first question but just in case, you can unarchive the form if you want to. You might have archived the form that's why it is moved to the archive folder.

    Thanks!

  • Profile Image

    Answered by macssam on July 11, 2014 at 08:51 PM

    I did not know about this "archive" feature

    now since I know this

    I tried to archive old forms but it did not work

    now it's suddenly working

  • Profile Image
    JotForm Support

    Answered by Welvin on July 12, 2014 at 03:12 AM

    I assumed the form revision history is already resolved. Am I right? Also, do you have an issue with archiving forms? We need to confirm! :)

    Thanks

  • Profile Image

    Answered by macssam on July 12, 2014 at 06:14 AM

    the slow and dropping internet

    as well as browser and OS incompatibilities with this site here

    are part of the problems

    entering the password to post a reply here does not work

    because this site tends to "hang" and I have to refresh constantly

    an save my text elsewhere so it does not get lost

  • Profile Image

    Answered by Carina on July 12, 2014 at 09:24 AM

    I cleared your forms cache to see if it helps. Relating to the Internet speed, I'm afraid there is not much we can do.

    You may also try to clear your browser's cache to see if it helps. Are you experiencing this difficulties in more than one browser?

    Let us know if the problem persists.

    Thank you

  • Profile Image

    Answered by sam  on July 13, 2014 at 07:46 AM

    the internet seed seems to be a major factor

  • Profile Image

    Answered by sam  on July 13, 2014 at 07:50 AM

    right now I can't even see any of my forms

    also the "edit" button here is not visible

    and I have to login again

  • Profile Image
    JotForm Support

    Answered by Welvin on July 13, 2014 at 10:50 AM

    Sam,

    You are currently using a guest account for posting your replies. You can't see any of your forms because you're not logged into your account. We also don't have any issues with editing forms, EDIT button is visible after choosing form from My Forms page. Please try it using another browser.

    Lastly, please contact your ISP if you have an issue with your internet speed. 

    Thank you!

     

  • Profile Image

    Answered by macssam on July 13, 2014 at 01:25 PM

    login never works

    this site hangs on me all the time ...

  • Profile Image

    Answered by macssam on July 13, 2014 at 01:27 PM

    why are the form fields for common languages like french not being translated automatically ...
  • Profile Image
    JotForm Support

    Answered by KadeJM on July 13, 2014 at 03:43 PM

    I checked your account, but I currently do not see any issues. Additionally, sometimes we can replicate such login issues if they are occurring, but we have not had any known problems involving this for some time now as far as I'm aware of.

    This leads me to believe there may be a connection issue on your end or it may be timing out within your network and that could be leading you to this problem. The reason can vary from your isp connection and usage to your network hardware or even your connection to our network especially if it is during our peaktime hours since we have millions of JotForm users that creates a heavy server load and that could cause slowdowns sometimes.

    However, as far as I know our devs have been doing everything they can to optimize this and reduce the problems related to this factor. Something I would recommend which should help is for you to reset your home network and clear your browser cache.

    Lastly, You asked another unrelated question to your original thread so I have moved it here