What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Grid Reports - Lightbox Causing Continual Loading Status

    Asked by markashton on July 17, 2014 at 07:23 AM

    Hi,

    A client contacted me to say that their grid report was constantly loading.

    I checked it and it was ... it contains filepicker photos ... and so I did the following ...

    Recreated the grid report identically to see if that solved the problem ... it didn't ... the new grid report was continually loading.

    Next I edited the grid report to turn off the modal lightbox option ... everything worked fine.

    So, this change solved the problem ... so would you be kind enough to see if there is a problem with lightbox in relation to the grid report usage ... or have you changed anything?

    Thanks Mark

    Reports status Grid Reports grid report problem next checked
  • Profile Image

    Answered by jedcadorna on July 17, 2014 at 10:09 AM

    Hi Mark,

    Are you referring to Product Lightbox widget which loads images in a lightbox in a form? I was looking for other lightbox, but I only see product lightbox widget and I'm unable to replicate the issue with grid reports.

    I'll wait for your response. 

  • Profile Image

    Answered by jedcadorna on July 17, 2014 at 10:16 AM

    Sorry, got it.

    I have now forwarded a ticket to our 2nd level. We'll notify you in this thread for updates.

  • Profile Image

    Answered by DedersSP on July 17, 2014 at 01:35 PM

    I I have the same problem at this moment! What can I do?

  • Profile Image

    Answered by markashton on July 17, 2014 at 01:39 PM

    Edit the report .... turn off the modal lightbox option ... that did it for me.

  • Profile Image

    Answered by DedersSP on July 17, 2014 at 01:49 PM

    OK already provided. But JotForm notifies you when repairing?

    Thanks

  • Profile Image
    JotForm Support

    Answered by Mike_T on July 17, 2014 at 03:03 PM

    @DedersSP,

    Yes, we will update both support threads once the issue is fixed. You will be notified.

    Thank you.

  • Profile Image

    Answered by markashton on July 18, 2014 at 05:35 AM

    What's going on with this?

    I've got a client on my back ... that's what they pay me for ... they like to use the modal thing as they don't want to leave the page ... market researchers for you.

    I've checked this and it is the same .... not working

    Can you advise please. Thanks

     

  • Profile Image
    JotForm Support

    Answered by Welvin on July 18, 2014 at 07:49 AM

    Hello Mark,

    I am sure the assigned developer is already looking into this matter since the priority of this ticket is high.

    You will be notified via this thread when updates are available.

    Thank you for your patience!

  • Profile Image

    Answered by markashton on July 18, 2014 at 10:05 AM

    I've got no patience Welvin ... so don't thank me for it ... just fix it now!

    Tell me ... how can it work one minute and then be broken the next?

    Who has f****d with the code ... and then not tested it properly .... or do you just rely on people like me to do all that and report it?

    Shall I pass you the telephone number of my client so that you can say that the problem is with your sh***y system and not with me?

    This is about the fourth time that this phenomenon has shown itself since the lightbox was introduced ... so I predict it will happen again ... and again ... and again ... to the detriment of my business not yours.

    Please advise me if there is anything you disagree with in my statement above.

    Tell me who is working on it at this moment .... who is the assigned developer? Ken ?

    Thanks Mark

  • Profile Image
    JotForm Support

    Answered by Welvin on July 18, 2014 at 11:18 AM

    I'm sorry, Mark. Rest assured that our developers will be looking into this problem, fix it and let you know here. I know our developers are doing their best to address this kind of bugs to our features. 

    The ticket was assigned to our developer PaulSimpson. 

    Our apologies and thank you!

  • Profile Image
    JotForm Support

    Answered by paulsimpson on July 20, 2014 at 09:18 PM

    Hi Mark,

    Apologies for the delay in replying to this thread. For some reason I did not get the notification that the bug had been assigned to me. I have just issued a fix for this. It should already be live now but if you are still experiencing problems you may need to reset the report config again.

    If you are still having problems after this, please reply to this thread and I will look into it straight away.

    Sorry for any inconvenience this has caused you.

    Paul

  • Profile Image

    Answered by markashton on July 22, 2014 at 09:41 AM

    This problem still exists: http://demomr.myresearch.info/grid/33036484322045

    I've re-saved the report ... taken modal off, turned it back on ... same probloem.

    I'm not recreating the report ... that link has gone out in hundreds of emails.

    Thanks Mark

     

     

  • Profile Image
    JotForm Support

    Answered by paulsimpson on July 22, 2014 at 10:25 AM

    Hi Mark,

    Sorry about that. There was a caching problem so your report was still being generated using the code from before the fix.

    Do you know if you have other reports affected by this?

    Paul