What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Image Picker Widget not working on source code embedded form in Wordpress

    Asked by fimep_srl on July 27, 2014 at 05:48 PM
    1) Imagepicker inserting source code into Wordpress Page doesn't show images (not resolved)
    image picker widget image widget widget script
  • Profile Image
    JotForm Support

    Answered by jonathan on July 27, 2014 at 07:22 PM

    Hi,

    I checked the embedded form in your website and was able to see the problem you mentioned.

    The Image Picker widget is not being shown in the embedded form.

     

    The problem is most probably caused by script conflict between the embedded form and those that in your website.

    Because using the direct URL of the form http://www.jotformeu.com/form/41900734049351  is NOT having this issue. As you can see on the image below, the Image Picker widget work just fine on the form.

     

     

    Since you need to use the form's source code to embed the form in your Wordpress website, here is my suggestion to fix the script conflicts.

    1. Create a separate stand-alone html page wthiin your website .

    Example, create the page http://www.fimep.it/jotform-fimep_srl.html (it does not have to be an html page, it can be any web page where you can embed the form using its source code)

    2. In the stand-alone page embed the form using its source code.

    So, if you follow step#1, the URL http://www.fimep.it/jotform-fimep_srl.html  when opened should contain the embedded form http://www.jotformeu.com/form/41900734049351

    You can also include all the custom scripts you need for the form (those scripts in the solution provided by our colleague Steve on this thread http://www.jotform.com/answers/405474)

    3. Test that the stand-alone page http://www.fimep.it/jotform-fimep_srl.html  with the embedded form should be working without any issue.

    If there is any issue with the stand-alone page, inform us so that we can check on it.

    4. You will now need to embed the stand-alone page into the original web page where you have initially embedded the form using its source code -- this web page http://www.fimep.it/form-preventivo/

    In embedding the external page (stand-alone page) to the website http://www.fimep.it/form-preventivo/  use iframe tag so when embedding.

    It should be something like this code

    <iframe allowtransparency="true" src="http://www.fimep.it/jotform-fimep_srl.html" frameborder="0" style="width:100%; height:3130px; border:none;" scrolling="no"></iframe>

     

    5. When done correctly, the form should now be embedded in your website  within an iframe thus it will prevent any script conflict.

     

    Hope this help. Please inform us if you need further assistance on this.

     

    Thanks!

     

     

     

     

     

     

     

     

  • Profile Image

    Answered by fimep_srl on July 28, 2014 at 02:35 AM

    Hi, thanks for your great work but the form is still not working.

    Using link: http://www.jotformeu.com/form/41900734049351 it shows at the end when submitting this even all fields are completed:

    After I created html page as you described testing in local but imagepicker has the same issue:

    look here: http://1drv.ms/1pllAvd

     

    I'm taking time for delivering work but plz take a look urgently.

    Giovanni

  • Profile Image
    JotForm Support

    Answered by ashwin_d on July 28, 2014 at 05:01 AM

    Hello fimep_srl,

    I did check your web page where you have your form embedded but it seems you have not followed the steps suggested by my colleague @jonathan. You should actually embed your form in an iFrame to avoid code conflicts.

    Coming back to your question related to "Incomplete Values", I was able to replicate the issue you are having with your form's direct URL. It always gives an "Incomplete Values" error even if all the required field are filled. I am reporting this to our back end team. We will get back to you as soon as we have any update from them.

    Thank you!

  • Profile Image

    Answered by fimep_srl on August 26, 2014 at 02:04 AM

    URGENT PLZ...

    Hi, I appreciate the great work you made for me for this trouble. I've followed all the steps that Jonathan wrote to me.

    Before I conclude the form and I give the site to the final customer I've the last issue. The html file with the form source code is perfect but the script on http://pastebin.com/T0N6ekqr inside the html file doesn't work. I attach the html file so you can check it.

    Form.html

    Best regards

    Fimep_srl

     

  • Profile Image
    JotForm Support

    Answered by ashwin_d on August 26, 2014 at 03:35 AM

    Hellofimep_srl,

    I did take a look at your script code and also the form source code you have shared. It does not seems to work when the check boxes are checked.

    I would suggest you to explain your requirement of enabling and disabling the check box option of your form and we will try to help you with a solution.

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by fimep_srl on August 26, 2014 at 06:08 AM

    I don't understand your question, sorry. The script code worked before I put the source code into a html page, so now I need to resolve the issue. What I've to do?

    Thanks

    Fimep_srl

  • Profile Image
    JotForm Support

    Answered by ashwin_d on August 26, 2014 at 07:34 AM

    Hello Fimep_srl,

    There seems to be some syntax error in your script. I added a simple alert box to be displayed on the click even but it does not seems trigger the function.

    Since it is new question, I am moving your question to a new thread and you will be answered in the following thread:  http://www.jotform.com/answers/420488 

    Thank you!