What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Configurable List Widget not triggering required validation error.

    Asked by bkurniawan on August 04, 2014 at 11:41 AM

    Hi,

    I am trying to figure out what is going on with the Required attribute for the configurable list widget? There are couple issues. Please see below for the issues. I really appreciate that someone can shed some lights on these issues.

    1) The warning sign does not showed up. Please see the screenshot #1

    2) Sometimes it works, and sometimes it won't. There were times that you are allowed to submit the form even the required Configurable list is not filled. Please compare the screenshot #1 with screenshot #2. 

    3) Somehow after you have filled the configurable list, i purposely removed the entries, and i was able to resubmit the form. 

     

    Screenshot #1

     

    Screenshot #2

    configurable list style uploads jpg compare
  • Profile Image
    JotForm Support

    Answered by EltonCris on August 04, 2014 at 12:27 PM

    Hi there,

    Thanks for reporting and we greatly appreciate for taking the time on adding screenshots.

    1. Regarding on the issue number 1, this is how it actually works. There's no warning error designed on this widget itself (within its iframe boundary) that's why there's no warning message displayed under it just like how normally a field does, but it should trigger the error warning message for the entire field when there are required fields unfilled or left empty on the widget field.

    Example:

    2. Make sure the widget field is set as required, the widget required option can't work independently unless the widget field is required.

    Example: 

    3. Sorry but I cannot reproduce this part. Please make sure the widget field is set as required as explained on number 2. The form will not submit unless the required fields are filled.

    Let us know if you have further questions. Thanks!

  • Profile Image

    Answered by bkurniawan on August 04, 2014 at 01:23 PM

    Hi,

    Thank you for your quick respond. Somehow after removing the one that were having issues, and rebuilt it with your suggestions, it works properly now. I will keep you posted if these issues pop up again. 

     

  • Profile Image
    JotForm Support

    Answered by david on August 04, 2014 at 01:45 PM

    Hi,

    On behalf of my colleague you are very welcome.  Please do let us know if you have any further issues and we will be happy to help.

    Thank you for using Jotform!

  • Profile Image

    Answered by bkurniawan on August 04, 2014 at 02:03 PM

    Hi,

    If possible, I would like someone to look at my form. I have recreated the configurable list field on page 2 of my form, but somehow it allows user to advance to the page 3 even the configurable list field was not filled as long as other fields on page 2 were filled.

    Here is my form source: http://form.jotform.us/form/41625779671163

  • Profile Image
    JotForm Support

    Answered by EltonCris on August 04, 2014 at 02:21 PM

    Hi,

    Thanks for your reply and for reporting the problem. I was able to reproduce it here. I have now raised this thread to our developers for a resolution. You will be informed here once this is resolve.

    Thanks!

  • Profile Image

    Answered by bkurniawan on August 04, 2014 at 02:22 PM

    Thank you. I have to give you guys "kudos". You guys are fast. :)

  • Profile Image
    JotForm Support

    Answered by david on August 04, 2014 at 02:50 PM

    No worries, we are here to help!  Hopefully we will have a resolution for you soon.

    Thank you for using JotForm!

  • Profile Image

    Answered by bkurniawan on August 22, 2014 at 03:29 PM

    Hi,

    I want to follow-up on the status of the bug that I reported earlier. Can you provide me with any status update?

  • Profile Image
    JotForm Support

    Answered by david on August 22, 2014 at 04:15 PM

    Hi,

    We are very sorry it is taking us a while to get to this.  It has been assigned to a developer and we hope to have a resolution for you soon.  I do not currently have a time frame as to when unfortunately.

  • Profile Image
    JotForm Support

    Answered by widgets on January 16, 2015 at 01:56 AM

    Hi, yesterday we made an update on the widget regarding this matter. And I would want you to test it out and report back to us if you still experiencing the said problem.

    Let me know your experience with it.

    Regards,
    Widget Team