browsers supported

  • Profile Image
    heartlandhsc
    Asked on August 06, 2014 at 11:18 AM
  • Profile Image
    ashwin_d
    Answered on August 06, 2014 at 12:14 PM

    Hello heartlandhsc,

    We do support most of the browsers and you should not have any issue. We recommend using Chrome and Mozilla Firefox but you should be able to use other browsers as well. We also support IE browser and you should not have any issue from version 8 and above. 

    Hope this answers your query.

    Do get back to us if you have any questions.

    Thank you!