Salesforce Integration API not supported error