What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Notification/Auto Responder Long Text Not Getting Mailed

    Asked by tmi on August 31, 2011 at 03:07 AM

    Team,

    Form Number: http://form.jotform.com/form/12415737174

    Notification that I want to send is named CP-4

    Issue: Cannot configure a long notification :(

    I have been trying to configure both of the above for a form of ours for the last 3 hours. There seems to be a limit to the text/character that can be put into these mails. I have tried configuring using HTML as well as simple paste. I have pasted from Docx, from Source File directly into the HTML. I have also pasted from a text file.

     

    Over the hours, the originally configured text cuts at different places. I am pasting a copy of the last notification's last few lines:

     

    representation as to future matters without having reasonable grounds for making it.

    e.      No Conflict

                                                        i.     Should proactively steer clear of conflict of Interest situations when doing business with TMI.

                                                       ii.     Where Conflict of Interest situations is deemed to arise (real or perceived) an upfront documented declaration of the same should be done to the TMI personnel engaging the services of the Partner. A copy of the document (an email or fax) should also be sent to parxxxxs@tmixxxrk.com

    f.       No Collusion

                      &n

     

    Please help.

    Page URL:
    http://form.jotform.com/form/12415737174

    Screenshot
  • Profile Image
    JotForm Support

    Answered by liyam on August 31, 2011 at 12:16 PM

    Hello tmi,

    I have checked your source code and noticed that your code seems to have tags that came from MS Word (or something similar to it).

    This normally causes email contents to break up once received by the recipient, depending on the email client that was used. Some would even go missing (hidden).  The culprit here is the special SGML tags used by the Word ediitor.  These tags are not normal to HTML so others return the special tags become hidden.

    I would suggest that instead of directly copy-pasting from word to email content, It would be best to copy the content then paste to notepad, then paste to the email content, then manually format your message in the editor.

    This is to prevent the formatting of the Word editor to be embedded into the form editor's email notification editor.

    Hope this information sheds some light to your concern.  If my suggestion did not solve your problem, just let us know.

    Warm regards,

    Liyam

  • Profile Image

    Answered by tmi on September 01, 2011 at 12:43 AM

    Liyam,

     

    I did try pasting through word pad, text file, html, mhtml. The problem does not get solved. Could you set this up for me? I really need this to work. Will save my team loads of time and mistakes.

     

    Thanks and regards

    Rajesh

  • Profile Image
    JotForm Support

    Answered by abajan on September 01, 2011 at 08:13 AM

    Hi Rajesh

    Perhaps it might be better to upload the original Word document (or better yet, a PDF version of it) to a file sharing service like DropboxRipway or another one and then include a link to it in notification and/or auto-response. That way, everyone who clicks the link will see the text as it ought to be formatted. (This is especially true in the case of the PDF version).

    If this sounds like an acceptable solution and you need any help setting it up, please let us know.

    Thanks.


    ~ Wayne

  • Profile Image
    JotForm Support

    Answered by abajan on September 01, 2011 at 09:16 AM

    Rajesh

    Actually, now that I've looked at your actual C-P4 notification (which is what I should have done in the first place) my solution won't work because how are the tags to be imported into Word?

    Will have to investigate this further to come up with a workable solution.


    ~ Wayne

  • Profile Image

    Answered by tmi on September 02, 2011 at 10:55 AM

    Wayne,

    I need a workaround. You folks come up with some suggestion please.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on September 02, 2011 at 11:35 AM

    Hi,

    Have you tried testing the form lately? I cloned it on my account and made a test submit. The autoresponder sent to my address appears perfectly fine, without any part getting cut off. Please see screenshot below:

     

    It's either whatever you did worked wonders, or the mail client you're using, Outlook, is acting up. Please do some testing and let us know how it goes.

    We'll wait for your updates. Thank you!


    Neil

  • Profile Image

    Answered by tmi on September 02, 2011 at 10:56 PM
    Neil,



    Please copy that form to my instance. My attempts at cloning led to complete stopping of all notifications from both the parent and the clone J I have given up. Once you have saved the form in our instance, just drop a mail.



    Thanks and regards

    Rajesh Kumar



  • Profile Image

    Answered by TMI on September 02, 2011 at 11:03 PM

    Neil,

     

    Please copy that form to my instance. My attempts at cloning led to complete stopping of all notifications from both the parent and the clone J I have given up. Once you have saved the form in our instance, just drop a mail.

     

    Thanks and regards

    Rajesh Kumar

  • Profile Image
    JotForm Support

    Answered by NeilVicente on September 03, 2011 at 01:58 AM

    Rajesh,

    Actually, I did not do anything to that form nor change the problematic autoresponder's settings. I just cloned it as is, deleted the other notifications and autoresponders (to avoid sending false alerts to your actual form's recipient e-mails), then sent a test submit.

    Still, you asked for it, so I have imported the cloned form onto your account. The name of the new clone is [JotForm Support Clone] Partner Communication Form. May I remind you though, that only the CP4 autoresponder is left for I have deleted the others before testing.

    Do send us a message if you have other issues that need attention. Thanks!


    Neil

  • Profile Image

    Answered by tmi on September 03, 2011 at 01:12 PM

    Neil/Wayne,

     

    I think I have solved this issue. In the file saving options under microosoft word, there is an option called "Filtered-Web Page." When we save our file in this file format, the "MS Word" specific codes are filtered out.

     

    We can not either paste this directly into jot form emailers or paste the source. It works! You guys owe me a treat for this :)

  • Profile Image

    Answered by allanftd on September 03, 2011 at 01:46 PM

    Way to go, Rajesh! Glad that you were able to sort it out yourself, and thank you for sharing the solution to other JotForm users.

    JOTFORM SUPPORT