What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form Group-Collapse function has stopped working

    Asked by john.roscoe on August 12, 2014 at 01:47 AM

    Today I have found my enrolment form is broken because the condition to show/hide a group of fields has suddenly stopped working. Nothing has been changed in my form and I have also tested an earlier clone of the form I have used for testing and this also has the same problem. 

    Please use the clone to test - the form ID is http://www.jotform.com//?formID=42080536693962

    To test - if you enter all details on page 1 and choose Status at Assembly = Associate it should display the 'Open Associates' group. Similarly if you choose Status = Observer it should display the 'Open Observers' group.

    Nothing displays on the page - just the NEXT button

    Please be aware this is a live form and in use for enrolling delegates, so an urgent fix is much appreciated.

     

    Page URL:
    http://www.jotform.com//?formID=42080536693962

    stopped working JotForm problem status next
  • Profile Image
    JotForm Support

    Answered by ashwin_d on August 12, 2014 at 09:09 AM

    Hello john.roscoe,

    I did check your form's condition and it seems you have one condition which always skips to page 3. I am not sure if this is correct condition. Please check the screenshot below:

    Apart from this, you form seems to work as expected. Please check the screenshot below:

    Have you embedded this form in your web page where it it not working? Please share the web page URL and we will take a look.

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by john.roscoe on August 12, 2014 at 05:56 PM

    Hi - thanks for your reply

    "I did check your form's condition and it seems you have one condition which always skips to page 3. I am not sure if this is correct condition."

     Yes this is the correct condition but it gave me an idea - I added a header field to page 3 and made it hidden and now it works correctly! It seems that a 'skip to page' condition needs 'somewhere to land' before it can perform the next step (which is to display either one group or the other). 

    What I cant figure out is why this has worked perfectly for over 5 months but not now - maybe I changed something but cant remember doing so. Anyway now its fixed thank you.