Form does not submit

  • Profile Image
    jearnest
    Asked on September 01, 2011 at 11:32 AM

    Hello -

     

    I was referred to your group by a web developer that's had a lot of success with your site and services and I am trying this out for a Customer Satisfaction Survey -- and for some reason when i test it ((preview) on your site directly everything is working fine.   The form posts (embeds) in my site fine, but it wont go to thank you message or trigger emails when submitting from my site??

     

    Any ideas?

     

    Thanks.

     

    John Earnest

    jearnest@rainbowdesign.net

  • Profile Image
    NeilVicente
    Answered on September 01, 2011 at 03:19 PM

    Hi John,

    The form is embedded inside another <form></form> tag in your page that is why it is not working properly. If you noticed, no matter how many times you submit the form, the notification e-mail is not sent, the thank you message is not shown, and the submission entry is not saved in the form's submissions page.

    Please remove these tags if they are not needed. Also, it would make sense to use either iFrame or Embed methods for your form to avoid script conflicts. If you notice now, field validation in your form does not work due to these script conflicts.

    To get your form's iFrame or Embed codes:

    1.  Go to Setup & Embed tab
    2.  Click Embed Form
    3.  Click iFrame or Embed

    4.  Copy the codes provided in the succeeding screen

    Hope this helps. Let us know if you have other issues or concerns.


    Neil

  • Profile Image
    jearnest
    Answered on September 01, 2011 at 03:51 PM

    Neil -- you're the BEST!!!  Thanks.  Works perfectly now.  I knew it couldnt be too complex....  LOVE the results.  Thank you!!!

  • Profile Image
    NeilVicente
    Answered on September 01, 2011 at 04:09 PM

    Glad to know I made a good impression to a new JotForm user. Thank you for the kind words!