Submission Email: Randomized Symbols appear in place of Apostrophes

  • Profile Image
    njfowler
    Asked on August 18, 2014 at 07:51 AM

    hi, I wonder if you could help me out with an answer as to why symbols are being inserted into form submissions in place of and apostrophe.

    example:   "Caller's husband and son were part owners of men's club. It went into insolvency and closed down. Now the debt is paid and he's entitled to some sort of claim payout. They have received a letter saying they have 14 days to claim. They have no idea how to apply for it."

    i have blacked out the rest of the message to highlight the error.

    any insight as to why this is happening is appreciated, thanks

    Candace

     

  • Profile Image
    KadeJM
    Answered on August 18, 2014 at 10:01 AM

    You are referring to the discombobulated symbols that appear in you form when an apostrophe is used as an input within your form here if I am correct?

    As far as I know we had fixed it some time ago, but it seems that it is back again and we do deeply apologize about that. 

    Is that from the description field on your form? Or?

    Jumbled Examples:

    Caller's =  Caller's

    men's = men's

    he's = he's

     

  • Profile Image
    njfowler
    Answered on August 18, 2014 at 10:20 AM

    Hi, The examples above are from the description field but I have also had them in the name boxes too. a name like O'Toole would show up wrong when I get the email through. or mike & emma would show up as : mike &nbsp:emma. any idea how we can get this fixed?

    thanks

    canadce

  • Profile Image
    KadeJM
    Answered on August 18, 2014 at 10:33 AM

    I apologize about my short response which was because I had been investigating it more. I've discovered that this seems to happen if more than one symbol is used since in my first test that was not happening.

    However, after testing this furthermore I was able to replicate the issue (see below). I've gone ahead and sent over a report about this to our developers so they can take a look at it anyway.

    Testing -

     

  • Profile Image
    njfowler
    Answered on August 18, 2014 at 11:30 AM

    That's great, thanks for your help :)

  • Profile Image
    njfowler
    Answered on August 20, 2014 at 08:46 AM

    hi, its happening with the form on this page now too: http://www.solicitorsdirect.org/ask-a-question/4580491198

  • Profile Image
    ashwin_d
    Answered on August 20, 2014 at 10:03 AM

    Hello njfowler,

    Thank you for the information. My colleague was able to replicate the issue already.

    We have already sent a bug report to our back end team and we will get back to you as soon as we have any update from them.

    Thank you!

  • Profile Image
    robinowsley
    Answered on August 20, 2014 at 01:33 PM

    I just thought I'd chime in, hopefully I can get an email when this is updated.  I'm having the same problem.  Anyplace an apostrophe is inserted (I'm instead of I am), I'm getting the random character crap mentioned earlier in the thread as well.  And, my forms haven't changed, nor has my method of download.  Also, it has only been the last 3-4 days of submissions . . . the problem didn't exist before that for several months previous with the same form.  I'm having to manually edit submissions to get this crap out of there.  I didn't bother checking with support for a couple of days, hoping the problem would resolve without me whining about it, but it has annoyingly persisted.

     

    Hope there's a fix soon!  

  • Profile Image
    liyam
    Answered on August 20, 2014 at 02:39 PM

    Hello Candace,

    I've fixed the bug. If you find further issues with any of your forms, please do let us know.  We'd love to hear from you :)

    Thanks and warm regards,
    Liyam

  • Profile Image
    robinowsley
    Answered on August 20, 2014 at 03:54 PM

    I just did another download to check.  The problem is still happening in my download.  New submissions (since the above post saying the problem was fixed) and the older ones as well, both  I'm seeing the substitution in the viewing window on this site as well as within my Excel download.

     

    In short, nothing seems particularly fixed here.

  • Profile Image
    sagetree
    Answered on January 19, 2017 at 01:48 PM

    Hi Jotform,

     

    I am having this same problem with my form today. My apostrophe is showing up as '

    See screen shot below. Any idea how to fix this?

     

  • Profile Image
    BJoanna
    Answered on January 19, 2017 at 03:45 PM

    @sagetree 

    I have moved your question to separate thread and we will provide you an answer there shortly. 

    https://www.jotform.com/answers/1040064