What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form doesn't work on Internet Explorer

    Asked by volvoracer122 on September 06, 2011 at 04:12 PM

    Hey folks, I have created a form and (unfortunately) sent it out to customers without testing it first on IE.  The form works perfectly on Chrome and Firefox, but will not show the image on IE.

    How can i fix this?  I dont mind sending back to the customers again, I just want to make sure it works...

    http://form.jotform.com/form/12412400168

    This is the direct link to the file.  It is what I am using as my hyperlink value on my email message out.

    http://ideoninvites.tumblr.com/post/9886831663/tumblr-html-code is the Tumblr one that still wont work on IE

    http://ideoninvites.tumblr.com/post/9886860618/iframe is the iFrame code that doesnt work either!

    Thanks

    Cameron

  • Profile Image

    Answered by brx250 on September 07, 2011 at 05:51 AM

     

     

    Hi Cameron, 

    First of all, thank you for using JotForm. 

    I've tried replicating your issue on our end and everything seems fine. If you could somehow point out the particular problem encountered when viewing/using the form, that would be great.

    However, you can try deleting your cache and use http://www.jotform.com/form/12412400168 instead of http://form.jotform.com/form/12412400168 especially in your iFrame embedding code such as shown below and see if it helps.

    <iframe allowtransparency="truesrc="http://www.jotform.com/form/12412400168"frameborder="0scrolling="no"> </iframe>

    If the problem still exists, feel free to inform us about the situation and our team will be more than willing to assist you with the best that we can do.

     

    _____________________________________________    

    Albert  JotForm  Support

     

  • Profile Image

    Answered by sdionne on September 16, 2011 at 03:16 PM

    I just wanted to add that I was having a similar program with forms not showing up in Internet Explorer that showed just fine in Chrome and Firefox, and changing the URL to http://www.jotform... from http://form.jotform... fixed the issue perfectly. Thanks!

  • Profile Image

    Answered by AmandaCanfield on September 17, 2011 at 12:59 PM

    I also am having problems in Internet Explorer.  My first page will show up, but once the next button is hit it will not progress to the next page. It shows the first page, but will not continue with the Next button. Please help!

     

    http://form.jotform.com/form/12513227888

  • Profile Image
    JotForm Founder

    Answered by aytekin on September 17, 2011 at 01:12 PM

    We have fixed the problem on the form.jotform.com forms early this morning. They should be working fine now. Let me know if the problem continues for any form.

  • Profile Image

    Answered by sdionne on September 19, 2011 at 11:17 AM

    Oddly enough, *I'm* now having a problem with displaying one of the images on my form in IE; another image is displaying just fine, and all of them are working in Chrome & Firefox. Any suggestions?

    http://www.xcendgroup.com/metrix-real-time-dashboard-support/

  • Profile Image
    JotForm Founder

    Answered by aytekin on September 20, 2011 at 06:08 AM

    Can you post a screenshot of the problem? 

  • Profile Image

    Answered by AmandaCanfield on September 21, 2011 at 01:36 PM
    I have just started all over from scratch, something about my format and the
    HTML was preventing the form from working, and I am now redoing it, making
    sure I do not copy any unwanted HTML format in with it. Thank you

  • Profile Image

    Answered by brx250 on September 21, 2011 at 09:23 PM

    Hi AmandaCanfield,

    We're glad you've come up with a workaround already. You can inform us for any updates so that we can provide further assistance regarding your issue.

    You're response will be greatly appreciated. Thank you and enjoy using JotForm.

    _____________________________________________    

    Albert  JotForm Support  

  • Profile Image

    Answered by FlashpintGallery on October 02, 2011 at 10:32 PM

    I'm having a similar issue with serveral jotforms in explorer.  When users press "submit" they get a "please wait" message and the form never processes.  

  • Profile Image

    Answered by allanftd on October 03, 2011 at 01:55 AM

    Hi FlashpintGallery,

    May we ask which of your forms is having this problem and also the URL of the website where they are currently embedded? Also, would you know which IE version are they using to access your form?

    We'll await your response so that we can assist you further. Please let us know if you have any other questions or concerns.

    Thanks,
    Allan

     

  • Profile Image

    Answered by mauckbaker on January 04, 2013 at 02:44 PM

    Hello, I have been having problems with IE as well. I attempted adding http://www.jotform instead of the http://form.jotform as suggested above, but to still no avail.

    Any suggestions on how to make the IE version align properly display? I have included an image of both internet platforms with the form displayed.

    IE and Firefox

    I appreciate any help quick!

    - Lauren

  • Profile Image
    JotForm Support

    Answered by jonathan on January 04, 2013 at 03:04 PM

    @Lauren

    Hi, is the form embedded on a website? Can you please share to us the URL of the website where the form was used? This information will help us check further.

    On initial test using your form's direct URL both on Windows 7 IE8 and IE9 browser, I could not reproduce the issue you mentioned.

     

     

    Thanks.

  • Profile Image

    Answered by GillesGDV on February 16, 2017 at 09:56 AM

    Hello,

    i have the same problem with Explorer 8 for windows and Opera for OSX :

    the form is not visible.

     

    My form : https://form.jotformeu.com/jsform/70452752235352

    The page : http://moa.douane.gouv.fr/articles/a12556-les-cellules-conseil-aux-entreprises

     

    Help please ?

  • Profile Image
    JotForm Support

    Answered by Kiran on February 16, 2017 at 12:24 PM

    @GillesGDV,

    Your question is moved to a separate thread and shall be addressed there shortly. Please follow the link below:

    https://www.jotform.com/answers/1068341

    Thank you!