Radio Button default selected option get cleared when reset button is pressed. Only when autofill is enabled

  • Profile Image
    ztwersky
    Asked on September 01, 2014 at 10:47 AM

    There are two great things about the forms

    1: If the browser closes, it will save the entered fields so you don't have to type them again.

    2: You can set a default value for any field - this saves users to have to enter ALL the data that is usually the same.

    The problem is that when the user comes back another day to enter a new purchase, the old data is still on the form. But when he clicks "Reset" - ALL the values go blank - even the ones I set to be default values! I want it to "reset" to it's default values.

    This is not good. How to fix this?

  • Profile Image
    jedcadorna
    Answered on September 01, 2014 at 12:03 PM

    Since your Autofill's Time To Live is set to 1 day if the user didn't clear there browser's cache then possible that they will still be able to pull up the old data. What you can do is try reducing Time To Live to 5hrs or 10hrs so the next day the user views the form the old cached data will no longer show.

     

  • Profile Image
    ztwersky
    Answered on September 01, 2014 at 12:11 PM

    Your answer is relevant to the new subject line that someone changed but that wasn't my question. I don't mind if the data is still there the next day. What I mind is that when he clicks the "Reset" button, all of the fields that I defined default values for are also cleared and this shouldn't happen. Thank you.

  • Profile Image
    Welvin
    Answered on September 01, 2014 at 01:23 PM

    Do you mean the Radio Button, right?  You can test it here: http://www.jotformpro.com/form/42435584789975. It should suppose to work like the one in textbox; the default value is there.

    Let me forward this thread to our developers. We'll see if what their response about this matter.

    Thank you!

  • Profile Image
    ztwersky
    Answered on September 01, 2014 at 03:41 PM

    Ok, Thank you.

  • Profile Image
    ztwersky
    Answered on September 04, 2014 at 01:39 AM

    Yes, it's been fixed. Thank you!!

  • Profile Image
    ashwin_d
    Answered on September 04, 2014 at 02:56 AM

    Hello ztwersky,

    On behalf of all my colleagues, you are welcome.

    Do get back to us if you have any questions.

    Thank you!