What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Stuck with error message and form disappears when you go back

    Asked by hartmutgunther on September 03, 2014 at 01:22 AM

    Hi guys - just launch my online business but have a urgent problem.

    When someone does the assessment  - using a jot form form  - URL below - and they don't fill in a required field and then hit submit they get the error message below  - problem is the screen is stuck and they can't get back to the form.

    This has happened several times over the last few days.

     

    Please help

    Site is live

     

     

     

    Page URL:
    https://www.toxno.com.au/assess.html

    Screenshot
    message required field problem site
  • Profile Image

    Answered by hartmutgunther on September 03, 2014 at 01:30 AM

     

     

     

    Sometimes it works and you get this screen - which is fine - but other times get the other nasty screen with no where to go???

  • Profile Image

    Answered by hartmutgunther on September 03, 2014 at 01:36 AM

    Also this is a message from a client

     

    " I don't see a field that says 'I have fully completed part 1" anywhere. I had a look on two different browsers, Internet Explorer and Firefox and tried submitting on both and still get the same error message. Have filled in all parts and ticked all boxes I needed to etc. If I use back button to go back to form on Internet Explorer it clears the fields and I have to start again, with Firefox the fields stay filled in when I go back, but still no extra field to confirm completion using either browser."

     

     

  • Profile Image

    Answered by hartmutgunther on September 03, 2014 at 01:50 AM

    Looks like I may have fixed the problem.

     

    One of the required fields was ALSO a hidden field. I turn off "required" and looks like now OK.

     

    Could you please confirm that this is actually the case.

     

    all the best

     

    Hartmut

     

     

  • Profile Image

    Answered by jedcadorna on September 03, 2014 at 06:58 AM

    I encounter the error message you mentioned above when you first load the page but when you refresh the site the validation works fine. The form disappears when you click on go back.

    Try to re-embed the form using Iframe method to avoid conflict with some of your JS libraries. That could the reason why the validation is not working correctly.