What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Embedded form fields are not fillable

    Asked by ptehc on September 11, 2014 at 07:43 PM

    Well, I had a form and it was working on my temp site. When I had published my site, it didn't work no more. I can't write in the boxes and summit any forms? Can you help.

    Page URL:
    www.ptehc13.com

    form fields fill-able fields
  • Profile Image
    JotForm Support

    Answered by Welvin on September 11, 2014 at 10:21 PM

    Hi,

    The form is here: http://www.ptehc13.com/contacts.htm. The problem is probably caused by a script conflict. Try re-embedding your form using our iFrame method: http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code.  This should help you fix it. If not, please update us here so we can find another solution.

    Thank you!

  • Profile Image

    Answered by ptehc on September 11, 2014 at 10:42 PM

    Yeah I don't know. I click on the form again. Didn't work. Your Iframe method didn't even take me to a site. Thanks for the help anyway buddy.

  • Profile Image
    JotForm Support

    Answered by ashwin_d on September 12, 2014 at 02:58 AM

    Hello ptehc,

    Though I am not sure why the form field in not editable in your web page but the embedded form is not a JotForm. It seems you have embedded Form2Pay form in your web page. Your direct URL of your form is :  http://www.form2pay.com/publish/publish_form/154130 

    As suggest by my colleaguem please go ahead and grab your form's iFrame embed code and use it in your web page. See if that solves your problem. 

    Thank you!

  • Profile Image

    Answered by ptehc on September 12, 2014 at 07:24 PM

    Yeah buddy I tried form2pay also to see if it was Jotform that wasn't working. However form2pay don't work either. I don't know what to do next. I tried the iframe like you said and you'll never guess. It didn't work either. hahaha. I'm lost now. I've tried to contact people including Xara and nobody as got answers. I guess only I could come up with a problem that nobody can solve. hahaha

  • Profile Image

    Answered by jvd042012 on September 12, 2014 at 08:08 PM

    Are you using Xara Web Designer Tool? What if you manually edit the HTML file then embed the iframe on the appropriate location just like what the Jotform support said.

  • Profile Image

    Answered by Pat  on September 12, 2014 at 08:33 PM

    Okay I'll try that after hockey.  But I'm kinda stupid when it comes to computers and code. So explain exactly what I need to do. Thanks man. 

  • Profile Image
    JotForm Support

    Answered by Welvin on September 12, 2014 at 10:01 PM

    Hi Pat,

    I will also try to look into this, I have your web source codes and tried it for a few minutes, but couldn't make it to work. Maybe, this is something because of the div elements or element indexing.

    Thank you!

  • Profile Image

    Answered by ptehc on September 12, 2014 at 11:27 PM

    This is weird, I tried everything. It won't work. HAHAHAH. It works fine with the preview (F5) so what can we narrow it down to. If it work good on the preview and won't work good on the net the what can be the problem? Something is missing.

    Pat

     

  • Profile Image

    Answered by ptehc on September 12, 2014 at 11:57 PM

    Okay now, I tried making a new page and it didn't work. I tried making a new tab in Xara and previewed it (F5) and it worked. So now it had to be something with my webpage that i built. Maybe something in the settings. Just trying to give you guys ideas.

  • Profile Image

    Answered by ptehc on September 13, 2014 at 12:21 AM

    Hey guys please try it now I think i got it. LOL. What I have done was I had it as a Page Backround. It was suppose to be on a Mouse over. I had uploaded it and published it. See if it work guys and let me know. Thanks a million fellows

    Pat.

  • Profile Image
    JotForm Support

    Answered by ashwin_d on September 13, 2014 at 03:20 AM

    Hello Pat,

    I did check your web page where you have embedded your form and it seems to be working fine. 

    I am glad to know that you were able to resolve this issue yourself.

    Do get back to us if you have any questions.

    Thank you!

  • Profile Image

    Answered by ptehc on September 13, 2014 at 07:29 AM

    Awesome guys. Now we know if this problem comes again and there using Xara we have to check where they embedded it. Everyone was awesome here. Thanks again everyone for trying to fix my problem. You kinda sold me to Jotform now just from the help that was provided.

    Thanks again

    Pat

  • Profile Image
    JotForm Support

    Answered by Welvin on September 13, 2014 at 08:44 AM

    Hi Pat,

    It's our pleasure to help! Please do not hesitate to get back to us if you need further assistance.

    Thank you for using Jotform!