What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Resources not loading over secure connection including captcha and other elements

    Asked by norm27 on September 29, 2014 at 08:15 AM

    Hi there - this is EXTREMELY URGENT.

    I am running many many forms on Jotform and I seem to be having the same issues through all of them.

    Here is an example form that demonstrates the problem:

    https://secure.adminplus.co.za/apps/CaCELL.html

    That is form ID https://secure.jotformpro.com/form/40774684485973

     

    - The captcha is not loading correctly (screenshot attached)

    - The lock icon image and various other secure images are not loading

     

    Extra INFO:

    These forms are using the secure embed iframe method

    I have many secure submissions left on this account 

     

    Please get back to me immediately if possible, this is very important.

    I need a solution please!

    Thanks in advance,

    Kind Regards

    Page URL:
    https://secure.adminplus.co.za/apps/CaCELL.html

    Screenshot
    Submissions JotForm secure images not loading https SSL secure elements
  • Profile Image

    Answered by Ben on September 29, 2014 at 10:43 AM

    Hi,

    I see what you mean from the screenshot, but I do not see that happening on the jotform, neither when I go to your website nor on the jotform when I go to it directly.

    In both cases I saw the lock icon near the top and the captcha at the bottom.

    It seems to me that there was an issue loading some elements for you at that time. Do let us know if this is still the case.

    In case you do see that happening I suggest Clear form cache. This should give you the fresh version of your jotform and erase the one that we have in cache.

    I will erase your jotform cache for you now, but do let us know if you see this issue happening again.

    Best Regards,
    Ben

  • Profile Image

    Answered by norm27 on September 29, 2014 at 10:58 AM

    Hi Ben.

    Thanks for your feedback.

    Try it in IE or Firefox for example.

    I am still seeing this issue with my forms: here is another example:

    https://secure.adminplus.co.za/apps/Algebra.html

    I have cleared form caches and browser caches - still happening.

    I have lots of forms, and it seems to be happening across all of them?

     

    If we could get to the bottom of it, I'd really appreciate it, I am running lots of forms with Jotform and it needs to be sorted asap please.

    Thanks in advance for your attention to this matter so far.

    Kind Regards.

  • Profile Image

    Answered by norm27 on September 29, 2014 at 11:25 AM

    Ps to the above:

    Lots of my images are broken / not loading either.

    These are images uploaded to Jotform for display in form - when viewing their source, and accessing the asset / image directly at its URL, I'm getting the 'One more step' validation request from Jotform itself??

    See this:

    Has this got something to do with your new servers/ hosting environment etc? Cloud flare etc?

    That is, these images (and the Captcha related images) are being blocked from Jotform's servers side by the looks of it.

    All these forms were working correctly, and they all seem to be having this issue now. (With secure embed, and Iframe method.)

    Please rectify this as soon as possible, clients are calling up asking what's happening. 

    Thanks in advance, looking forward to a solution.

    Kind Regards

  • Profile Image

    Answered by Ben on September 29, 2014 at 11:34 AM

    Hi,

    I see. It seems that you are not seeing any other images neither based on this new screenshot.

    What I would suggest is to do this:

    Click on start menu -> Run

    type cmd

    and press "OK" button

    When a new black window is shown please type next ipconfig /flushdns

    You should see this message

    Windows IP Configuration

    Successfully flushed the DNS Resolver Cache.

    Do let me know if this resolves the issue of getting the resources.

    I had originally tested with Firefox and now with IE which seems to have had the issue, but the above resolved it for IE.

    If this helps you to access your jotform, then others will be able to do so as well shortly, it would mean that the DNS entries related to jotform were old.

    However I am not sure why you are getting captcha prompt so I will be contacting our developers to take a look at this as well if you can confirm that the issue is not fixed by the above command.

    Best Regards,
    Ben

  • Profile Image

    Answered by norm27 on September 29, 2014 at 11:49 AM

    Hi there.

    Nope. This has not resolved the issue.

    I am running something like 20+ forms with you guys.

    I ran the flushdns, I am still not seeing the resources - when viewing in dev tools, and hitting the resources directly at their URL, I still get the validation request as per my previous post. (ATTENTION REQUIRED! Cloudflare etc)

    These forms need to work correctly the way they were before please, I have two accounts that I pay for with you guys and I've been using Jotform for many years - please help out here, I can't use work-arounds here, something must be up with the WAY the resources are being served lately..?

    Thanks again, really appreciate it.

    Kind Regards

  • Profile Image

    Answered by Ben on September 29, 2014 at 11:58 AM

    Hi.

    Thank you for getting back to me. I will now notify our developers about this issues and they will take a look at what is the reason this happens.

    They will keep you updated through this thread.

    Best Regards,
    Ben

  • Profile Image

    Answered by Ben on September 29, 2014 at 12:07 PM

    Hi,

    Just to confirm the developers are notified.

    Also, if you have the same issue with your other account as well, please tell us the username for that account so that our developers can look into it as well.

    Best Regards,
    Ben

  • Profile Image

    Answered by norm27 on September 29, 2014 at 12:11 PM

    Hi Ben thanks.

    For now, the critical forms are on this account - I need them working right away, I rely on Jotform, I hope that they can get this resolved right away. (It seems my resources just aren't loading correctly from their upload locations, but that wouldn't explain the Captcha's resource issues, as they load from a different source surely?

    Let's hope they can correct this, I might need a new system for these forms if not.

    Kind regards,

  • Profile Image
    JotForm Support

    Answered by david on September 29, 2014 at 01:47 PM

    Hi,

    I checked your website just to follow up and see if all the resources were loading and everything appears to be loading fine.  All the images load and the captchas load not matter which browser I use:

    Left is FireFox, middle is IE, and right is Chrome.  I was experiencing a bit of slowdown earlier also with my whole forms loading and saving, but the issue seems to have settled.  There is still an open ticket regarding this issue just to make sure there isn't something going on with another server.  You are correct though, images and widgets such as the captcha one, are indeed loaded from different sources.

    In regards to the security check, it should only make you do it one time then it adds your IP to our whitelist. 

  • Profile Image

    Answered by norm27 on September 29, 2014 at 02:21 PM

    Hi David.

    Thanks for the feedback.

    The issue we're having is from a a usability perspective for the hundreds of people using these forms.

    1. a user accesses our forms

    2. the images don't load and neither does the capture

    3. the user leaves and reports an error to us, ie. they cannot submit their information

    (We have had approx. 10 issues logged today alone)

    --------

    In trying to troubleshoot this issue, we have accessed the resources directly to see what's going on, which is where we found that validation step etc.

    There is no prompt automatically, the resources just don't load in the user's browser - and we cannot expect public users to view the elements in dev tools and go through the validation to get added to the whitelist. (?)

    Please try this from a mobile device or another network etc, we have tested from an entirely different AP and the issue is still there.

    Please help us to resolve it properly - users having to get themselves added to an IP whitelist can't be right?

    Thanks again, I really do appreciate your input.

     

  • Profile Image

    Answered by Ben on September 29, 2014 at 03:04 PM

    Hi,

    I have opened a ticket with our developers and they are looking into the issue and the possible causes. My colleague David wanted to confirm that he as well as myself, did not get these issues so that our developers have as much data as possible.

    If you can tell us (that is if you have this info) if the users that had this issue, such as yourself are in the same part of the world, or the same county? This would help our developers localize the issue, which as you see is not effecting all of us, but I assure you that it will be handled as if it does.

    If your users have reported any technical details that you think that might help, feel free to add them here as well.

    Best Regards,
    Ben

  • Profile Image

    Answered by norm27 on September 29, 2014 at 03:17 PM

    Hi again.

    Same country (South Africa), I've tested on different devices, same issue. 

    The only factor common to everyone having the issue seems to be that they have not been added to the IP whitelist through that Cloudflare step - (obviously as we don't know who'll use the forms beforehand, and these are members of the public / new users etc)

    Just another clue for you guys - as I'm still not seeing the resources load on my side:

    1.  the resources only show in Chrome, and only because I've gone through the whole validation / adding my IP (?) through the extra validation step we undercovered by trying to access directly. We are still not able to see them in FF or IE as I've not done that validation / cloudflare captcha step (discussed in detail above) in the other browsers

    2.  So, I pulled one of the images and uploaded it to our own (SSL secured) server, and JUST that particular image shows up (in IE and FF) no problem.

    3. So it seems that if they are being served from from my JF account's 'upload space', the issue happens, if it's served from anywhere else, solved.

    4. Also, under my 'Account' dropdown, oddly, it shows 0b of 10gb used?

     

    Please keep me posted, I need to have this rectified for all my forms (and the 5 or 6 images in each) - it's not viable of course to try pull them all and upload to our own server - I need all these forms working asap.

    Thanks again, looking forward to a solution.

  • Profile Image
    JotForm Support

    Answered by david on September 29, 2014 at 04:28 PM

    Hi,

    Thank you again for the information, we will update you in this thread as soon as our developers have an information.  Usually for new questions we split them off to a new thread but in the case of (4, this is a very short answer.  If there are no files associated with your uploads, your submissions will not take up any storage space.  The actual submissions themselves do not take up any space.  We are very sorry for the inconvenience and hope to have a resolution for you soon.

  • Profile Image

    Answered by norm27 on September 30, 2014 at 03:08 AM

    Hi guys.

    Please let me know what the status of this issue is.

    I need to answer my clients.

    Thanks again,

    Kind Regards

  • Profile Image

    Answered by jedcadorna on September 30, 2014 at 07:21 AM

    Hello,

    This ticket has been already assigned to our dev though this is marked as important, we can't promise any date on when this will get fixed. What we can assure you is you will be notified here once an update is available. 

    Thank you for your patience and we apologize for any inconvenience.

  • Profile Image
    JotForm Support

    Answered by liyam on October 04, 2014 at 06:31 AM

    Hello norm27,

    If you have a Google Chrome browser, can you check if the captcha fails also on that end?  If so, can you press F12 and reload the form again and share if there's an error that appears?

    You can also try this on Firefox, if you have firebug installed you can press F12, reload the form and check on the console of there is an error that appears.

    Looking forward to your response.

    Thanks.

  • Profile Image

    Answered by norm27 on October 04, 2014 at 07:30 AM

    Hi liyam,

    Here is the error that shows up in the console in FF.

  • Profile Image

    Answered by Ben on October 04, 2014 at 07:37 AM

    Hi Norm,

    Thank you for updating us on this issue with a screenshot.

    Our developers will let you know what should be done next through this thread once they inspect the screenshot and the possible reasons why this error would be shown.

    Best Regards,
    Ben

  • Profile Image
    JotForm Support

    Answered by liyam on October 04, 2014 at 07:42 AM

    Hello,

    I still can't identify the cause of this.  Can you try using recaptcha and see if this works?

    Thanks.

  • Profile Image

    Answered by norm27 on October 04, 2014 at 07:52 AM

    Hi liyam.

    Yeah, thanks for looking at it.

    It's not just the captcha though. Check the whole thread and you'll see, I've already given you as much detailed information as I could possibly give you.

    Including the fact that the resources load great from our own SSl server etc.

     

    1. Yes to your question - it works fine when recaptcha is enabled.

    2. Many of the images are still not loading

  • Profile Image

    Answered by Ben on October 04, 2014 at 08:20 AM

    Hi Norm,

    Can you please contact your ISP and ask them to inspect why their servers are not allowing resources from our secure servers to be loaded.

    If you can, forward their response to us on this thread.

    This is what our developers suspect to be happening as had happened before on few occasions and was result of the ISP of our clients blocking the resources to be loaded or reached.

    These are the links that I would like to ask you to verify with them:

    static-interlogyllc.netdna-ssl.com

    jotform.com

    https://s3.amazonaws.com/

    I presume that your ISP did not allow the connection to follow a redirect to other resources over HTTPS

    Also can you please tell me if the images (lock at the top, admin+ and orange image above submit button) load on this form for you?

    http://form.jotformpro.com/form/42763436674968

    Looking forward to your response.

    Best Regards,
    Ben

  • Profile Image

    Answered by norm27 on October 04, 2014 at 09:17 AM

    Hi is see them now that I've completed the cloudflare verification question.

    If I get those answers from my ISP, what about the rest of the public users of these forms? They were working fine until recently.

    You are correct in your assumption:

    " presume that your ISP did not allow the connection to follow a redirect to other resources over HTTPS"

    I have mentioned this early in this thread, but it is true for many users countrywide. 

    NB: the cloudflare verification step is a newer addition to this equation - we didn't have this years ago and I have only recently noticed it myself - naturally I filled in my validation and I've now been added on your side, to an IP whitelist. (Maybe you guys could investigate from there, this is a major change somewhere in their security protocols etc.)

    As mentioned previously in this thread, this is OK for myself but not for all the public users of these forms.

    As I mentioned before, I have tried this from a mobile device on an entirely different network with the same result. 

    As I mentioned before that, clients have reported it from all over the country on various ISPs.

    Also, like I said before, this has started happening recently. Perhaps you could find out from your side why the resources are being served differently? I serve them from my own SSL servers and there is no issue.

     

    I do appreciate your trying to help, but perhaps my years with JF are drawing to a close and I'll need to find another provider if this problem cannot be solved.

    Kind Regards,

  • Profile Image
    JotForm Support

    Answered by Jan on October 04, 2014 at 10:28 AM

    Hi norm27,

    I understand your frustration norm27. We would like to thank you for the detailed information that you provided here, that will really help our developers to discover what the issue is. It shows that it is still under investigation for now. This thread will be updated as soon as they found out the what the problem and the solution is. We apologize for any inconvenience. Thank you again.