What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Problem with Spinner function

    Asked by drocmx on September 30, 2014 at 01:23 AM

    Hello, I am having an issue when using a Spinner function (in the "Survey tools" menu).

    I added the Spinner OK to my form (see the top half of the screenshot attached)

    - I made the Spinner an obligatory field so the person filling out the form can not leave it blank, and I set the minimum to 1 and the maximum to 4.  OK (see the bottom half of the screenshot)

    - I need the default to be "blank", so the person filling out the form can not accidentally skip the field and leave a default as 1 (for example).  This is where I have the issue.

    In the bottom half of the screenshot, in the properties of the Spinner, I set the default value to blank (I do not put a number), I save the form, and for the first time I load the form in the browser, it accepts that default as "blank", and everything is OK.  When filling the form, I am forced to enter a number from 1-4 into the Spinner.  No problems.

    I am sure to save my form.

    The second time I load the form in the browser, it does not have the default as blank, but as 1.  Then when I look into the properties of the Spinner, I see that the default value has changed to 0 (even though it shows 1 in the form in the browser).

    Am I doing something wrong here?  Maybe I am using the wrong function (Spinner) for this type of task...?

    Thanks!

    Julius

    Page URL:
    http://form.jotform.co/form/42721356071853

    Screenshot
    problem survey survey tools maximum tools
  • Profile Image
    JotForm Support

    Answered by Welvin on September 30, 2014 at 06:39 AM

    Hi,

    That is because you have a minimum value of 1. Therefore, you cannot add 0 as the default value.

    Thank you!