Use SFTP instead of FTP for the submissions to be transferred to my server

  • Profile Image
    Christopher Gauntt
    Asked on September 30, 2014 at 06:31 AM

    I'm having trouble connecting.


    First off, I tried using my SFTP settings, but the "test connection" wheel spun forever. It'd be nice to make SFTP an option since we deal with fairly sensitive documents sometimes.


    Secondly, when I switched back to regular FTP and port 21, the test connection succeeded. However, when I was brought over to the folder list, I just got a spinning wheel. It never resolved.


    In this instance, I created a unique ftp user account just for this purpose. Since I could not use sftp, I had to pick a shell ftp account type option. I went with bin/bash, but that didn't work. My other options are:






    Can you let me know what the best settings are?



    This is a re-post of a comment on How to Send Submission Data & File Upload via FTP

  • Profile Image
    Answered on September 30, 2014 at 09:14 AM

    Hi Christopher,

    Unfortunately it does not seem that SFTP is an option available at this time, but I will raise a ticket to our developers so that they take a look at it and they might decide to implement this feature.

    Now regarding the issue with the FTP wheel spinning up, you will need to change the setting 'is passive' to get the list of the folders shown to you.

    Without is passive (for my ftp setup)

    With passive enabled:

    If you are not sure if you are using active or passive, try changing the option and clicking on next and when the folders / directories are shown that is the correct setup.

    Do let us know if you have any further questions.

    Best Regards,

  • Profile Image
    Christopher Gauntt
    Answered on October 03, 2014 at 02:31 AM
    Hi Ben,
    I appreciate the feedback and suggestions, but the wheel keeps spinning. Doesn't matter if I check the passive box or not.
    I double checked the ftp account that I set up, and it definitely has folder access permissions set up. Testing the connection works fine, so I know I have the correct server / username / pw combo.
    Is there some other rule I about setting up folders I should know? The folder I want to upload to branches off the root level, not the website level for security reasons. And I made sure the account had read/write access to it.
    also, might it be the type of shell account I assigned to it? I'm using bin/bash (Recommended default, but there are other options.
    We can use Drop Box if we absolutely have to , but it makes the work arounds way more complicated on the backed when we download an import the submission data into our system.
  • Profile Image
    Answered on October 03, 2014 at 05:29 AM

    Hi Chris,

    Please make sure you have the right privilege permission (write permission) on your target ftp folder.

    Usually a CHMOD 755 should be enough.


    I just checked this on my test FTP account, and I was not able to reproduce any problem.

    Please check if the FTP account you used have sufficient access permission on the target upload folder to be used in the FTP integration.


    With regards to the SFTP option, our colleague Ben had already submitted a feature request ticket for it. There is no available time frame though when or if this will be implemented. We will have to wait for update from our dev team when available.

    They will provide response here for any status update when available.


    Please inform us if you are still not able to resolve the FTP issue