Showing N/A value with empty field when data is transferred to Salesforce from Zapier

  • Profile Image
    nichelleh
    Asked on October 01, 2014 at 09:13 AM

    I am using Zapier to transfer data to Salesforce but when fields are empty the N/A is throwing a wrench into my plan. Is there a way to remove N/A from empty fields and leave them empty?

     

  • Profile Image
    jedcadorna
    Answered on October 01, 2014 at 10:56 AM

    If I understood you correctly you are using Zapier to integrate Jotform to Salesforce? The N/A text shows in Salesforce or Zapier?

    Can you please provide a sample so we can check.

  • Profile Image
    nichelleh
    Answered on October 03, 2014 at 08:45 AM

    Yes, that's correct. The N/A text shows in Zapier, and therefore also in Salesforce.

    Any empty field displays as:

    In salesforce, when the field has a required format, N/A is not accepted and the whole zap is rejected.

  • Profile Image
    jedcadorna
    Answered on October 03, 2014 at 09:18 AM

    This could be an issue with zapier integration to salesforce since when you are integrated to salesforce and you left a required field salesforce won't store the submitted data base on my test. The integration with salesforce and Jotform doesn't have any problem passing required and non required field.

    What I suggest you to do is open a ticket at Zapier about required fields displaying as N/A if left empty then you can tell them that support from Jotform made some integration test and didn't find any problem with required fields.

  • Profile Image
    nichelleh
    Answered on October 03, 2014 at 09:57 AM

    Ok, thanks for looking into it.

  • Profile Image
    cheekyface
    Answered on September 09, 2015 at 03:34 AM

    Any resolution to this?  I've only just recently encountered this for a form I've been using for ages.  I'm sure it's zapier too but they take so long to reply.  I thought nichelleh may have a solution?

     

    Cheers,

    Danny