What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Quantity conditions not showing the correct fields

    Asked by rtis_admin_cangrad on October 03, 2014 at 11:13 AM

    I have a number of conditions set in my products and I wonder if the field names are causing a problem with the conditions.  It has to be that.. Can you take a quick look?

    The rule should be this:

    If Package A quantity equals 1 then show: Package A details  Pose 1 field, Pose 1 finish, Pose 2 field, Pose 2 finish (which they all are) but its including the additional fields incorrectly.

     

    Second Rule:
    If Package A quantity equals 2 then show Package A details  Pose 1 field, Pose 1 finish, Pose 2 field, Pose 2 finish PLUS additional Pose 1 field, Add'l Pose 1 finish, Additional Pose 2 field, Add'l pose 2 finish (which is not showing).

     

    I've tried every other way of hiding and showing different rules and its not working.  I've looked at previous examples which have been posted here in the forum, but mine isn't working (which I believe is somehting to do with how I've labeled the fields) it has to be. lol.

     

    It should work like this for all four packages (I just haven't created the conditions for these yet as I haven't been able to make this one work.  What am I doing wrong here..?  (Thanks again) 

    Page URL:
    http://form.jotform.ca/form/42675709641260?

    Screenshot
    quantity additional fields quantity conditions conditions
  • Profile Image

    Answered by Ben on October 03, 2014 at 11:59 AM

    Hi,

    If I understood you correctly, you wanted to show 2 extra fields that did not show up.

    Now I was looking at Package A implementation and it seemed to be correctly entered. I had removed it and tried to create it from the start, but it did not work neither. Now the actual thing that worked was removing Package B, Package C and Package D conditions and setting them back up one by one (I was duplicating them).

    Unfortunately I can not tell you exact thing that should be changed so I offer cloning the jotform I made (How to Clone an Existing Form from a URL ). If you want to see what was the cause, remove the fields mentioned above in your conditions and just leave the Package A implementations.

    You can see the changed jotform here http://form.jotformpro.com/form/42754884699982

    This is the screenshot:

    Now what I would suggest is to create one set of fields at a time and work with that. Once you have it setup properly continue with the next set of fields. This way you know what was changed and stopped the things from working properly. :)

    If you have any further questions do let us know.

    Best Regards,
    Ben

  • Profile Image

    Answered by rtis_admin_cangrad on October 03, 2014 at 02:24 PM

    lol Ok - I will try that.  I'm glad it wasn't just me (that this occurred with).

    I will do that now and let you know if it corrected the problem.

    Thanks AGAIN for all your support.

  • Profile Image

    Answered by Ben on October 03, 2014 at 02:36 PM

    Hi,

    You are welcome and please do update us on how it goes. If you take a look at the link it is working (hopefully in the manner that you wanted it to)

    http://form.jotformpro.com/form/42754884699982

    If it does not let us know and we will take another look at it.

    Best Regards,
    Ben