Show conditions do not work

  • Profile Image
    ionutindreica
    Asked on October 06, 2014 at 04:28 PM

    Hi, i work on some forms for a special campaign. My problem is that the conditions are not working as they should... I need to see just the first part of the form, and depending on what option a user will select to show or hide the rest of the questions. I tried to put the conditions in the same order as the questions in the form ... not working, I even added an extra field to put some more conditions.. From a logical point of view ... if you insert a condition if --- field -- is == to something then do action - on field and I picked every field and added an action that was necessary for that conditionIs not very clear for me, do I need to insert the other cases in case is != to something ... The form I am talking about is here: http://www.jotform.com//?formID=42784336228359 http://form.jotformeu.com/form/42784336228359?At first it should show the first text box, and the next 3 fields. After that depending on what kind of GIFT they want they have to give the rest of the details needed to receive it.

    I also try to insert 4 buttons with 4 links to other 4 forms but i just do not know where should i insert the link for the new destination? Should I insert it as custom CSS with a different type of button? form here: http://www.jotform.com/?formID=42785444559367Thank you. Have a great day. Ionut
  • Profile Image
    Mike_T
    Answered on October 06, 2014 at 05:16 PM

    Thank you for contacting us.

    Your setup with the Show conditions is correct, but it seems that you have outdated values in conditions. I re-saved your conditions with the correct show fields.

    Make sure that you show the correct field on each condition to fix the issue.

    Example:

    http://form.jotformpro.com/form/42786731931967

    If you need any further assistance on this, please let us know.