Issues on the form

  • Profile Image
    juanarambarri
    Asked on September 28, 2022 at 10:10 AM

    Hello,


    When users click on the form the form breakes for a second and then it appears correctly but in UX terms is a little bit messy.


    Also when a user clicks "comenzar" at the beginning of the form the form goes full screen.


    Can you help me avoid both of those?


    Thank you!

    Page URL:
    www.biela.io

  • Profile Image
    Kris
    Answered on September 28, 2022 at 10:18 AM

    Hello Juan,

    Thanks for reaching out Jotform. I will need more information about the issue you are having with your form. Can you explain a bit more? Screenshots will be a great help for a better understanding, you can follow the guide from this link on posting screenshots in the support forum.

    Also, may I know which of your forms is having the issue? May I know the title of the form or the URL of the form? Is your form embedded on a website? This error sometimes happens if it is not embedded properly on the website.

    We can move forward as soon as we receive a response from you.

  • Profile Image
    juanarambarri
    Answered on September 29, 2022 at 05:05 AM

    Here are the screenshots


    This is how it starts in the first second.

    1664442123_63355f0b048b3_

    Then when I click on start it goes full screen

    1664442185_63355f49a75c6_

    Like this



    1664442221_63355f6dca88e_


    The forms are in here in the CTA button https://www.biela.io/

    There are two forms one in English and one in Spanish. In both cases the issues are the same


    Thanks!

  • Profile Image
    Kris
    Answered on September 29, 2022 at 05:34 AM

    Hi juanarambarri,

    Thanks for your explanation and screenshots. That helped me understand what is happening. Can you try to re-embed the form using the codes inside the iframe only and without the other script codes as shown below?

    1664443918_6335660e8d340_

    It could be that the script codes are having conflicts with the other codes on your website. Kindly give it a try and let us know how if the issue persists.


  • Profile Image
    juanarambarri
    Answered on September 29, 2022 at 06:28 AM

    Hi thank you for your reply


    It worked, but the mobile version is not ok. The form appears cropped. Any ideas?

    1664447307_6335734b6a738_

  • Profile Image
    Mary
    Answered on September 29, 2022 at 09:42 AM

    Hello juanarambarri,

    Could you please try adjusting the height property of the iframe?

    1664458832_6335a0503ce85_

    Give it a try and let us know how it goes.


  • Profile Image
    juanarambarri
    Answered on September 29, 2022 at 09:54 AM

    Hi Mary, but I would like to have the form as it is in the preview, that is, to be mobile responsive...


    Because by changing the height it won't solve the problem

  • Profile Image
    Waqas
    Answered on September 29, 2022 at 10:30 AM

    Hi Juan,

    Thanks for getting back to us. I cloned your form and tried to replicate the issue, but everything worked the way it should. Check out my results in the screencast below:

    1664461759_6335abbfb3b89_

    Sometimes, this kind of issue is temporary and it resolves itself. Can you give it another try and let us know what happens? If you're still having the same problem, we'll do a more in-depth investigation and work on finding a solution.

    Reach out again if there’s anything else we can help you with.


  • Profile Image
    juanarambarri
    Answered on September 29, 2022 at 10:33 AM

    Thank you for your response,


    Yes actually I embedded the form in a new page instead of a new window and the solved the issue.

    Thank you for your help


    Best

  • Profile Image
    juanarambarri
    Answered on September 30, 2022 at 11:37 AM

    Thanks for your response,


    Still, users go into full screen mode when they click con "start", do you know why that is happening? This is what I've shown earlier


    Thanks in advance!

  • Profile Image
    Waqas
    Answered on September 30, 2022 at 11:52 AM

    Hi Juan,

    Thanks for getting back to us. You can disable full screen mode from the Publish Tab in the builder. And embed it again on your website. Check out my screencast below.

    1664553046_633710567cbb9_Can you try it again and see how it goes? If you run into the same problem again, let us know and we'll do some more testing to see what's going on.