What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    JotForm conditions on multipaged jotform: Not jumping through the pages properly

    Asked by ashleycoombes on October 09, 2014 at 09:21 AM

    Hi,

     

    I created the form below using a series of "jump to page" conditions based on the selections made.

    I trialled it the day before yesterday and it worked brilliantly.

    I came back to it today to insert images in the relevant pages.

    The conditions no longer work - despite the fact they are showing in the edit boxes.

    I have removed the pictures - but it still isn't working - again despite the fact that the conditions are showing in the edit boxes.

    The form is here ...

    http://form.jotformeu.com/form/42794444173359

     

    Many thanks,

    jump insert images conditions revision history multi page
  • Profile Image
    JotForm Support

    Answered by Jan on October 09, 2014 at 10:56 AM

    Hi ashleycoombes,

     

    I checked and cloned your form and it shows that the conditions are working. When I select a specific option, it will then jump to the appropriate page. Am I missing something?

    If it was working fine before you put images then maybe this Form Revision History might help you. Here's our user guide on How to View Form Revision History. It will let you revert the changes you made. 

     

    Hope this helps. 

  • Profile Image

    Answered by ashleycoombes on October 09, 2014 at 11:51 AM
    Hi,
    Thanks so much for looking into this.
    Are you sure it is jumping to the right Page rather than simply going to the next page?
    EG if you check Perfetto on the first page It simply takes you to the next page ... which is chose the Album size for Apertura albums ( It's complicated and a lot of the pages seem very similar), when it should take you to the Perfetto Album size page ...
    I have tried this on 2 different computers and neither of them recognise the conditions.
    Can you send me a copy or link to the cloned form so I can try it on that one?
    It's really frustrating as I spent a whole day yesterday creating the form and it was working perfectly ... and should still be working perfectly.
    I have tried disabling all conditions and then switching them on again ... no change.
    I'll take a look at the form revision hstory in the meanwhile.
    Thank you!
    Anna
    ...
  • Profile Image

    Answered by Ben on October 09, 2014 at 03:05 PM

    Hi Anna,

    Yes, you are right it is taking to next page not to specific pages when clicked.

    Now I have taken a look at your jotform and what I can see currently is that here are 54 disabled conditions and 4 conditions with the fields removed and removed fields can cause such issues.

    I have inspected your jotform and the issue was indeed caused by these 4 fields. After removing them the jotform was working yet again. Now I would suggest taking a look at your conditions and checking what fields you had removed in order to know which pages would not get shown and if that is what you wanted to achieve.

    This is the link to the jotform http://form.jotformpro.com/form/42815987777981

    Now if you use the Revision Tool as suggested above by my colleague Jan you will be able to restore your jotform before the fields were removed (if they were removed by accident) and see if they are needed or not :)

    Do let us know if you have any further questions or need further assistance.

    Best Regards,
    Ben

  • Profile Image

    Answered by ashleycoombes on October 09, 2014 at 04:31 PM
    Dear Ben - thanks so much for that - I suspected it might have been something with those but was too nervous to remove them.
    It is working - and I have edited it a bit, and it is still working! Phew.
    I will try to insert the images again and hopefully the same thing won't happen again.
    ...
  • Profile Image

    Answered by Ben on October 09, 2014 at 05:42 PM

    Hi Anna,

    You are welcome. I am glad that it is working for you :)

    Do let us know if you get any issues after inserting images and we will be happy to help you sort it out.

    Best Regards,
    Ben