What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Bug: Conditions are not working on embedded forms but are working on standalone versions

    Asked by ICFforms on October 15, 2014 at 01:26 PM

    Hello,

    We received reports that the forms that are embedded into our site are not working correctly. I have a series of screen shots that I would like to share so please refer to the links at the bottom of this question.

     

    1.  The date fields that are on the form will populate so you can select the date but then they do not disappear once a date is selected.  The date field stays present on the screen through out the rest of the form and often blocks fields that need to be completed or blocks the next button (shown in the screen shots below) and you have to tab through and hit enter to move forward.  I have a series of screen shots that I would like to share so please refer to the links at the bottom of this question. Screen shots: A and B

    2.  When testing the embedded forms on our site I noticed that because the above date field was blocking fields that are required, I didn't think that I would be able to move forward on the application by clicking next.  However, I was able to move through the application as though the required fields were not there. Screen shots: C and D can also see from the screen shots used to capture the date field error as well (A and B).

    3.  Conditions are not working correctly.  On the form that I have linked on our website, there is a second on training where we ask them to select their program from a drop down menu.  If they select that it is not listed, they are supposed to be populated with a series of questions to upload additional materials.  These fields are supposed to remain hidden until they make the needed selections but they are showing up on the forms as though there were no conditions set. Screen shot E

    When I test these forms in the preview window in jotform they all work just fine, but they do not work on the embedded forms on our site.  This is happening with all of the forms that we have embedded in the site.  We have tested this with Chrome, Earthlink and firefox.  We cleared cookies and cache and tried again but had the same results.

     

    Screen Shots:

    A: http://imgur.com/6eatH8F

    B: http://imgur.com/cxzNAwK

    C: http://imgur.com/sDtQvXQ

    D: http://imgur.com/mxujTyi

    E: http://imgur.com/drx8nYQ (the questions including and following, "since you have selected that you training program is not listed...." are the fields that should not be showing on the form unless someone makes the correct selections from the dropdown)

     

    Any help would be appreciated.

     

    Thanks,

    Emily - ICF

    Page URL:
    http://coachfederation.org/accportf_app

    date field and Reports JotForm cache
  • Profile Image

    Answered by crsslo on October 15, 2014 at 01:28 PM

    Same here.

    Bump

  • Profile Image

    Answered by raul on October 15, 2014 at 02:47 PM

    Hello,

    I've escalated this ticket to our next support level.
    They will update it as soon as possible.

    Please accept our apologies for the inconvenience caused.

    Thank you.

  • Profile Image

    Answered by ICFforms on October 15, 2014 at 02:55 PM

    Hello,

    I appreciate it!  If you could give me any kind of estimated time line on when I can be updated, that would be helpful so I can communicate this with the company.

     

    Thank you,

    Emily - ICF

  • Profile Image
    JotForm Support

    Answered by paulsimpson on October 15, 2014 at 05:19 PM

    Hi Emily,

    Unfortunately there was a bug with conditional logic which was causing your problems. It has now been fixed. I have checked your form and it seems to be working now. However, if you are still having problems please let me know.

    We are very sorry for the inconvenience caused.

    Paul

  • Profile Image

    Answered by ICFforms on October 16, 2014 at 08:44 AM

    Hello,

    Thank you for following up with me.  I have checked our forms and they appear to be working correctly now.  I appreciate the help on this issue. 

    Thank you,

    Emily - ICF

  • Profile Image
    JotForm Support

    Answered by Welvin on October 16, 2014 at 11:25 AM

    You are very much welcome, Emily. It's great to know that your problem is now resolved. Should you need any further assistance with your forms, please do not hesitate to contact us again.

    Thank you for using Jotform!