MailChimp group subscription from a check box does not work any more

  • Profile Image
    lafototeca
    Asked on October 15, 2014 at 05:01 PM

    Hello.

    As of today, the exact same problem is happening with my account, so I guess the ticket shouldn't be closed.

     

    The adress for the form:

    http://www.lafototeca.org/diplomado/indexJotform2.php

    It is not using the checkbox to add the group information.

    Did it work before?

  • Profile Image
    aytekin
    Answered on October 15, 2014 at 06:02 PM

    So, the problem started happening again. We have just opened a new bug ticket about it and one of out developers will get back to you soon. Sorry about that. 

  • Profile Image
    NeilVicente
    Answered on October 16, 2014 at 09:11 AM

    @lafototeca

    The checkbox added by MailChimp's integration is for deciding whether the user would like to be added to your MailChimp mailing list or not.

    It is not related at all to the list group. All users added to your mailing list will be automatically added to the group you have selected, which is in this case, Deseo de recibir ofertas de Canella - Canon

  • Profile Image
    lafototeca
    Answered on October 16, 2014 at 01:33 PM

    @NeilVicente

    Yes, that is the expected behaviour.

     

    The problem is, even when they check the box that asks the user if they want to sign up, they are added to mailchimp but not to the group "Ofertas de Canon".

     

  • Profile Image
    david
    Answered on October 16, 2014 at 02:49 PM

    Hi,

    I went ahead an re-opened the ticket regarding this issue, to have our development team have another look.  The users should be added to the proper group setup in the integration and it appears it is not.  We will update you here as soon as we have any further information. 

  • Profile Image
    NeilVicente
    Answered on October 17, 2014 at 02:52 AM

    @lafototeca

    The bug was caused by a hyphen (-) on your group's name. 

    No need to anything on your part though as we have just released a fix for the said bug.

    Kindly inform us if there is anything else we can help you with.

    Best regards

  • Profile Image
    RockefellerCenter
    Answered on October 22, 2014 at 05:40 PM

    Hello, I have been following this thread and another related thread (http://www.jotform.com/answers/395659-My-Mailchimp-connection-is-not-logging-the-Group#7

    I am having an issue that is ongoing as of today, where I set up the integration with MailChimp and users are added to a list, but they are not added to the specific ones that I mark with the checkboxes.

    To illustrate, this is the JotForm that I am using:  http://www.jotformpro.com/form/42733155182957 

    In setting up the integration with MailChimp, I paste my API key, and then it brings me to the next screen.  I select the list I want "Rockefeller Center Updates" and then check off 3 boxes:

     

    However, when I test the form by submitting a response, my e-mail is not signed up for any of the 3 checkboxes.  In MailChimp, it shows that the e-mail is added; however, it is not assigned to receive any newsletters.  Screenshot from MailChimp (looking at the new e-mail that has been added as a result of filling out the JotForm):



    As you can see, none of the checkboxes are checked off.  Please advise.  Thanks!

  • Profile Image
    Charlie
    Answered on October 22, 2014 at 07:32 PM

    Hi RockefellerCenter

    Thank you for providing us details of your problem. But please open a separate thread, this will help us further assist you. And if you can add the screenshots again on the separate thread we'd appreciate it.

    Thank you.

  • Profile Image
    RockefellerCenter
    Answered on October 22, 2014 at 07:47 PM
  • Profile Image
    Jeanette
    Answered on October 22, 2014 at 11:00 PM

    I've answered to you on your own thread.