Form ID did not match error when Submitting Form

  • Profile Image
    jettogo
    Asked on October 15, 2014 at 05:34 PM

    I can complete my form, including additional pages, but when I submit, the pages cannot be displayed and the submission failes.

  • Profile Image
    Shadae
    Answered on October 15, 2014 at 06:29 PM

    Hi jettogo,

    I do apologize for the issue that you are experiencing with your form submitting.

    I checked the direct link to your form and was able to do a successful test submission. Can you confirm that you are still experiencing the issue?

    If you are still experiencing the issue, is your form embedded, if so can you provide us with the webpage that the form is embedded on?

    We await your response.

  • Profile Image
    jettogo
    Answered on October 16, 2014 at 10:47 AM

    Thanks for your response.  I tried it again and upon submission I still get the page cannot be displayed.  The form is not embedded.  It is launched as a new window from our website to the URL provided above.

  • Profile Image
    Shadae
    Answered on October 16, 2014 at 12:05 PM

    Hi jettogo,

    I do apologize that you are still having that issue with your form not being submitting.

    Could you attempt to clear your form cache. How to Clear your Form Cache.

    If you are still experiencing this issue can you tell us what browser you are doing the submissions in? Have you tried another browser?

    I hope this helps. We await your update.

  • Profile Image
    jettogo
    Answered on October 16, 2014 at 05:36 PM

    Same issue before and after clearing the form cache.  However, afterward, it still presents the page cannot be displayed, it eventually presents the following error.

    Error
    Form ID did not match. Form ID: Form Name: 12393933329
  • Profile Image
    Kiran
    Answered on October 16, 2014 at 06:24 PM

    I am not able to replicate the issue and I was able to send a test submission without any issues at my end. Also, as I check the submissions I notice a few submissions in between Shadae's test submission and mine. This could be the issue with browser's cache. Could you try clearing the browser's cache by following the instructions provided in the guide below to resolve the issue.

    http://www.wikihow.com/Clear-Your-Browser%27s-Cache 

    Please get back to us if the issue still persists. We will be happy to look into this issue further.

    Thank you!!