What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Images are not displaying on form

    Asked by DarynLouw on October 29, 2014 at 04:33 AM

    Hi 

    When i view my form the images dont display. 

    I have tried this on various browsers and computers but i have the same result. 

    the browser i created the form on the images display correctly. 

    Page URL:
    http://www.myjotform.com/form/42953946466570

    Screenshot
    images display images
  • Profile Image

    Answered by Ben on October 29, 2014 at 09:05 AM

    Hi,

    I tested it in several browsers, but I was able to see the images correctly.

    Can you please tell me which browser is showing the image and which ones are not (and the versions of them)?

    Best Regards,
    Ben

  • Profile Image

    Answered by DarynLouw on October 30, 2014 at 04:55 AM

    Hi Ben 

    I have tested on the following browsers on multiple computers on three various connections.

    PC 1 -> Windows 8.1 

    Firefox 32.0.3

    IE 10.0.21(I cant even get past the initial jotform capture)

    Chrome 38.0.2125.111

    No image displays 

    PC 2 -> Windows 7 Machine

    Firefox 32.0.3

    IE 11

    Chrome v 38 

    No image displays

    PC 3 -> Windows 7 

    Chrome v 38

    No image displays 

    PC 4 -> Windows 7 

    Chrome v38

    IE 11

    No image displays

    Ipad 

    Chrome  It displays 

    Safari   it does not display 

    Iphone 

    Chrome It displays 

    Safari It does not display 

    -----

    All the computers don't display the image. i have cleared cache etc. 

    Could this by any chance be due to my location being in South Africa.

    As I must say using browser stack and other online browser tests on similar browsers the image does display which makes me think my region has something to do with the issue?

  • Profile Image
    JotForm Support

    Answered by jonathan on October 30, 2014 at 08:10 AM

    Hi,

    I am not sure if this is region related issue. So far we do not have similar reported case from other users that have the same location you are.

    I also could not reproduced the issue on my end as I can view the full jotform just fine.

     

    Have you tried yet on a different network/internet? Perhaps it is on your internet connection only?

    Try this process also.

    1. Login to JotForm using this link http://www.jotform.com/login

    2. In your My Forms page, clone your form http://www.jotform.com/form/42953946466570 to your account.

    Follow this user guide http://www.jotform.com/help/27-How-to-clone-an-existing-form-from-your-account

    3. After cloning the form, check the cloned version if it was able to display the complete form.

    --

    If issue still persist try this method also.

    Open this link in your browser http://www.jotform.com/?noCDN=true

    Go to your My Forms page and preview your jotform. Check if issue is gone.

    Hope this help. Inform us if issue remains.

    Thanks.

     

     

     

     

     

     

  • Profile Image

    Answered by DarynLouw on October 30, 2014 at 09:37 AM

    Hi 

    I figured out what the cause of the issue is. Jotform constantly prompts for a captcha security check on initial login and occasionally while using the system. When i share the link with others they are first prompted to complete the captcha security check before seeing the form. 

     

    It would appear that the image link being hosted on Amazon AWS is also protected by this captcha. So when my form is loading it is actually looking for the captcha before it renders the image thus the image does not render in the form 

    https://s3.amazonaws.com/jufs/DarynLouw/form_files/Swish%20Logo.png

     

    When i host the image from another source the issue is displayed across all browsers and on all connections.

    Please do note this occurred on multiple network/internet connections at various locations. Home, office mobile data connections.

    Jotform seems to pick up connections in South Africa as suspicious. 

    The guidance given when requested to complete the captcha i feel is not helpful as our office has very strict antivirus and malware regulations so i don't believe this to be the cause of the issue. 

     

     

    "What can I do to prevent this in the future?

    If you are on a personal connection, like at home, you can run an anti-virus scan on your device to make sure it is not infected with malware.

    If you are at an office or shared network, you can ask the network administrator to run a scan across the network looking for misconfigured or infected devices. "

     

     

  • Profile Image
    JotForm Support

    Answered by jonathan on October 30, 2014 at 09:44 AM

    Thank you for providing us the detailed information.

    I checked your jotform again http://www.jotform.com/42953946466570 and I could not see the captcha field on it anymore. 

    Can you please confirm that removing the Captcha on your jotform resolved the issue now?

    Just to let you know also, the Captcha field purpose to is to block spam submissions. But we do have have also already within system anti-spam.

    What I am saying is, most of the time, without the Captcha field, the jotform should do just fine preventing spam.

     

    Thanks. 

     

  • Profile Image

    Answered by DarynLouw on October 31, 2014 at 02:31 AM

    Hi 

     

    I removed the capture field as this still does not display as the issue is the same as with other images. It cant display as it needs the jotform "One more step" security check captcha before it can display the captcha image on my form. 

     

    https://www.jotform.com/server.php?action=getCaptchaImg&code=573d0c04d7d6e274c5b152749cae821e

     

    i will proceed without this and host the rest of my images from an external source. 

     

    Thanks 

  • Profile Image
    JotForm Support

    Answered by jonathan on October 31, 2014 at 08:50 AM

    Thank you for updating.

    If you can, please update as also of the result of the latest procedure done if it makes the situation better. I will use the information to compare why it works when images are hosted on outside resource and not when in JotForm. I can use the details to raise a ticket to our higher team support so it can be investigated further.

    Thanks.

  • Profile Image

    Answered by Sasjot on September 01, 2015 at 08:52 AM

    HI, I added links of the photos already posted on facebook to the products using the forms wizard, but I only see a square with a question mark in it. Can someone please help me?

     

  • Profile Image

    Answered by Ben on September 01, 2015 at 10:08 AM

    @Sasjot since this is a thread of another user, and it is a different issue I have moved your post to a new thread here: http://www.jotform.com/answers/652502 which we will be answering to shortly.