Submit buttons does not submit, instead an error flashes.

  • Profile Image
    CTSFF
    Asked on October 31, 2014 at 12:08 PM

    Submissions are not going through after the submission button is clicked. A red error flashes under the button but does not stay on screen long enough to view message. 

  • Profile Image
    Ben
    Answered on October 31, 2014 at 01:49 PM

    Hi,

    The red text is most likely saying "There are errors on your form, please fix them". From what you describe however we would need to see your jotform on your website (or where this happens) to be able to tell you exactly what is causing this.

    Best Regards,
    Ben

  • Profile Image
    CTSFF
    Answered on October 31, 2014 at 01:54 PM

    http://www.jotform.us/form/42156182909155 

     

    (I recently put a second button for testing reasons, neither work)

  • Profile Image
    Ben
    Answered on October 31, 2014 at 02:57 PM

    Hi,

    This seems to have been caused by Terms and conditions widget.

    If you remove them for now, you will be able to continue using the widget while our developers find the reason why this happens.

    I will notify our developers of this and they will update you through this thread as soon as the fix is provided.

    As a possible substitution could be a plain radio button with the link to your terms of use such as on this jotform: http://form.jotformpro.com/form/43035342285955

    You can clone it to your account following these steps: How to Clone an Existing Form from a URL

    Best Regards,
    Ben

  • Profile Image
    Ben
    Answered on October 31, 2014 at 03:06 PM

    Hi,

    I have actually just noticed that you had an older version of the widget on your jotform.

    Simply removing the old one and adding a new one will fix the issue for you.

    You can see it in action here http://form.jotformpro.com/form/43036141859960

    Do let us know how it goes or if you have any further questions.

    Best Regards,
    Ben