What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Video playback not working in IE 10

    Asked by info@firmavercruijsse.be on November 04, 2014 at 11:50 PM

    I've made a jotform only with a video.

    I put this: http://iloapp.firmavercruijsse.be/video/public/3/141509614993096800_normal.mp4 in the form with 'youtube settings'.

    Than I put the form in my website.

    Now I have no problem when I open my website http://www.theuvelhof.be/ in mozilla or chrome; then I see my video. But in Internet explorer, he's downloading the video for playing it in windows media player???

    Why? What's the solution?

     

    Thank you,

    Piet, Flanders.

    PS. Can I make a loop with my video in jotform?

    Page URL:
    http://www.jotformpro.com/form/42974276801966

    video Youtube unable to play video video playback
  • Profile Image
    JotForm Support

    Answered by Welvin on November 05, 2014 at 02:12 AM

    Hi Piet,

    What's your IE Version? Maybe you need to install a flash player plugin for your IE browser. Checking it here using IE11 on Windows 7 doesn't give me any issues, the video is playing fine:

    Thank you!

  • Profile Image
    JotForm Support

    Answered by Welvin on November 05, 2014 at 02:12 AM

    Check this guide from IE, this should help: http://support.microsoft.com/kb/2532294

    Thank you!

  • Profile Image

    Answered by info@firmavercruijsse.be on November 05, 2014 at 05:58 AM

    Strange... I use windows 8, ie 10.  I asked my friend to do the same W8, IE 11, and he had the same problem... the video is playing in media player...???

    Java ,... is good installed.

    Any other solution? Is there sombody with windows 8 who want to check it?

    Thanks!

    Piet

  • Profile Image
    JotForm Support

    Answered by Jan on November 05, 2014 at 08:18 AM

    Hi,

    Are you able to play YouTube videos? If yes, then it is probably not a flash issue. 

    Try clicking the Compatibility View option in IE when you are on the website and see if it works.

    IE does not want you to view or play the video on the actual browser and just automatically gave you an option to open or save for security purposes. So it is a compatibility issue between the website and the browser.

    How did you embed that video on the form?

    What do you mean when you said you put the video with Youtube settings?

    Did you use the widget "Youtube"? If you use this widget, it will ask you to put the youtube video url. That means that the video should be uploaded to youtube first then copy the code and embed it here in JotForm. I would recommend this one because flash is compatible and trusted by most browsers (including selected old browser versions).

    Thank you.

  • Profile Image

    Answered by info@firmavercruijsse.be on November 05, 2014 at 09:49 AM

    I can play youtube video's.

    It is not actually a youtube video that I embed, it is a video that I put on my own server. Than I put the link http://iloapp.firmavercruijsse.be/video/public/3/141509614993096800_normal.mp4 in the youtube widget... and it works in Mozilla... but not for IE...  so that's the problem?

    How can I put my own video-link in Jotform?

    Thanks

    Piet

  • Profile Image

    Answered by Ben on November 05, 2014 at 10:37 AM

    Hi Piet,

    I presume that your Media Player is associated with .mp4 files hence it opening the file instead of the IE.

    I have tested my thought in my Windows XP that does not have flash set to open files and this is what I get (Firefox):

    In my Windows 7 machine it works without any problem, right after opening it, but not in IE, in IE it is asking to see what you want to do (well, I have it set like that), you are keeping it on default settings (most likely) which is why it just starts downloading.

    What I would recommend is to upload the file to youtube and then embed it on the page to see how it goes.

    An alternative could be to use flv video instead of mp4 one.

    Best Regards,
    Ben

  • Profile Image

    Answered by info@firmavercruijsse.be on November 10, 2014 at 01:31 AM

    Thank you for your help.
    I putted everything on youtube; was the easiest way.

    Piet

  • Profile Image
    JotForm Support

    Answered by Welvin on November 10, 2014 at 04:41 AM

    Hi Piet,

    It's our pleasure to help. So I think this issue is now resolved. Please do not hesitate to get back to us again if you need further assistance.

    Thank you for using Jotform!