What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form disappears on firefox and internet explorer

    Asked by INTAComunications on November 06, 2014 at 10:33 PM

    Hi. I created a form and it works perfectly on Google Chrome but when I try to see it using Mozilla or Explorer then it appears for about 0.5 second and desappears for forever. How can I fix it?

    Page URL:
    www.hirpyme.com

    disappear gone
  • Profile Image
    JotForm Support

    Answered by EltonCris on November 07, 2014 at 12:55 AM

    Hi,

    I can't seem to reproduce the problem here. Tried it with Firefox and the form does not disappear.

    Please try to clear your Firefox browser's cache and see if that helps. If not, re-embed your form using iframe embed code. This might help. https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    Please update us with the result. Thank you!

  • Profile Image

    Answered by Dolphin on December 17, 2014 at 06:45 AM

    Hi. I have the same problem like NTAComunications. The form works fine with Chrome, but on Mozialle firefox and Explorer it dissapears after 0,5 seconds. I've tried it with the iFrame-Code, but then I don't see anything. The form does not appear.

    Page URL: TruvirtuFormular

    Do you have any idea how I can fix this problem?

  • Profile Image
    JotForm Support

    Answered by ashwin_d on December 17, 2014 at 09:27 AM

    Hello,

    I did check your web page in firefox and I am able to replicate the issue you are having. Please check the screenshot below:

     

    There seems to be conflict between the three form script you have in your web page. I would also suggest you to embed all the forms using its iFrame embed code and that should solve your problem. 

    Do get back to us if the issue persists.

    Thank you!

  • Profile Image

    Answered by TruVirtu on December 18, 2014 at 03:36 AM

    Hi. I tried it with the iFrame, but it doesn't show my forms as well as with the source code... 

  • Profile Image
    JotForm Support

    Answered by ashwin_d on December 18, 2014 at 05:00 AM

    Hello TruVirtu,

    I did check your web page in firefox and it seems id does displays the two forms but NOT the first one. Please check the screenshot below:

     

    There seems to be some css related issue with the first tab. I will check it and get back to you later today.

    Thank you!