What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Next button not working

    Asked by regkhn on November 10, 2014 at 04:24 AM

    Hello!

    All of a sudden, the next button does not work in several in my forms (IE8 and Firefox). Form collapse is also not working. Why is this happening? It worked just fine last week (and the weeks before)? Mobile is OK.

    Here are a couple of ID's you can test:

    33493675173967

    23526268253960

    BR,

    Rune

    Page URL:
    http://form.jotformpro.com/form/33493675173967

    next button not working My Forms Mobile does not work
  • Profile Image
    JotForm Support

    Answered by ashwin_d on November 10, 2014 at 08:53 AM

    Hello Rune,

    I did check your form in Firefox & IE but I am unable to replicate the issue you are having. The next button along with the form collapse seems to work fine. I was also able to submit your form as well. Please check the screenshot below:

    Have you embedded this form in your web page where it is not working? Please share the web page URL and we will take a look.

    We will wait for your response.

    Thank you!

     

  • Profile Image

    Answered by regkhn on November 10, 2014 at 10:21 AM
    Hello!
    I still have the same problem. Nothing happens at all.
    My colleague has the same issue.
    We are working on the same network in a big company.
    Could it be that some parameter has been set “globally in the company” which makes this happen?
    I will also try the form at home on my Mac
    /Rune
    ...
  • Profile Image
    JotForm Support

    Answered by ashwin_d on November 10, 2014 at 11:28 AM

    Hello Rune,

    You did not answer if you have embedded your form in your website or you are using your form's direct URL. If you have embedded it in your website, we would like to take a look. Please share the web page URL.

    I have cleared your form cache from here. You may also like to clear your browser cache and see if that helps you. The following guide should help you in clearing browser cache:  http://www.wikihow.com/Clear-Your-Browser's-Cache 

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by regkhn on November 10, 2014 at 01:37 PM

    Hello!

    I am not embedding the form. I use direct URL.

    I will try to clear my cache next time I log into my work-network and give a feedback.

     

    /Rune

  • Profile Image

    Answered by Shadae on November 10, 2014 at 02:51 PM

    Hi Rune,

    Thank you for that information. Like my colleague, I was not able to replicate the issue on the direct link to your form

    We await your update regarding clearing your browsers Cache and trying the form again.

    Thank you.

  • Profile Image

    Answered by regkhn on November 11, 2014 at 10:56 AM

    Hello!

    I have now tested it on all type of browsers inside my company network. All of them does not work.

    Then I made my Iphone as a hotspot and tried "outside" the company network, and guess what? It worked.

    So, I guess this is some kind of setting done in our proxy or some global setting. I guess I need to take this issue to our own company helpdesk.

    If you have any idea in which direction I should point to them, it would be helpful. If not I think we can close this case. 

  • Profile Image
    JotForm Support

    Answered by ashwin_d on November 11, 2014 at 11:14 AM

    Hello Rune,

    That is strange. 

    I cannot figure out the issue how only the "Next" button and the "Form Collapse" button is not working within your company network. 

    I would suggest you to please click on the following SSL URL of your form and see if you are able to click on the "Next" button and the "Form Collapse" of your form:  https://secure.jotformpro.com/form/33493675173967 

    We will wait for your response.

    Thank you!

  • Profile Image
    JotForm Support

    Answered by abajan on November 11, 2014 at 11:18 AM

    Rune,

    Is your company network behind any firewalls? I think I recall another user with a similar issue sometime ago and we discovered that the firewall was the cause.


    Thanks

  • Profile Image

    Answered by regkhn on November 12, 2014 at 05:56 AM

    Hello!

    Yes, behind firewalls. Would be nice if you could point me in right direction on how to describe to our global helpdesk what my request would be?

     

    /Rune

  • Profile Image

    Answered by regkhn on November 12, 2014 at 07:20 AM

    Hello ashwin_d!

    Amazing!!

    Your form works ( https://secure.jotformpro.com/form/33493675173967 ),

    but mine still don`t ( http://form.jotformpro.com/form/33493675173967 ).

    So, what is the conclusion then?

    /Rune

  • Profile Image
    JotForm Support

    Answered by jonathan on November 12, 2014 at 09:22 AM

    Hi,

    As was suggested also, can you please try using testing using the secure URL of the form.

    Use this URL https://secure.jotformpro.com/form/33493675173967

    Inform us of the result.

    Thanks.

     

  • Profile Image

    Answered by regkhn on November 12, 2014 at 01:20 PM

    Hi.

    As I wrote in my reply over, it did work using the secure URL.

    I still wonder if you then are able to conclude why the un-sercure does not work.

     

    /Rune

  • Profile Image

    Answered by Ben on November 12, 2014 at 01:41 PM

    Hi Rune,

    It is good to hear that it is running when over SSL (secure URL). Now there could be many reasons why this works and the regular URL does not.

    For example, your company network can not see what is inside of the SSL data packet, it can only see from where the call was made (your PC) and where to (a file on one of our servers).

    Now if the firewall is blocking based on some content or elements it would not be able to see them and hence not be blocking them.

    Your firewall could also be set to trust more to encrypted connections over non-encrypted ones.

    What I would suggest is next:

    1. Contact your company IT department and ask them to check on this. They can see the logs and see what exactly is the issue and what policy should be changed.

    2. use secure link to your jotform instead of regular link in the meantime.

    Best Regards,
    Ben

  • Profile Image

    Answered by regkhn on November 13, 2014 at 02:27 AM

    Thanks team!

    I will do so.

    BR,Rune