Form is not forwarding data to MySQL Database using Send Post Method

  • Profile Image
    harry
    Asked on November 23, 2014 at 01:18 PM

    I submitted a form to my database but I searched the database and couldn't find the input. meanwhile it didn't display any error message



    This is a re-post of a comment on How to send Submissions to Your MySQL Database Using PHP

  • Profile Image
    BDAVID
    Answered on November 23, 2014 at 01:52 PM

    Could you please let us know what the form is? Make sure the Send Post Data option is set as "Yes", if it is set as "No", that most be the problem:

    Also, we would need to inspect the code, you could paste it in http://pastiebin.com/ and share it with us, let us know what happens, we will be glad to assist you.

  • Profile Image
    bltrecruiting
    Answered on December 15, 2014 at 06:45 AM

    Hello

     

    I have followed the instructions carefully in how to submit my jotform entries to mysql

     

    Here is my code;

     

    http://pastiebin.com/548ec91393f19#&togetherjs=yO9tlEyu3I

     

    I have followed everything, set my data to post etc etc. 

     

    When I submit the form, my entries do not get copied to my database on the server, also the code just displays in full after my thank you message.

     

    I have been looking at this for hours and would really appreciate some help or guidance.

     

    Thank you 

     

     

     

     

  • Profile Image
    Welvin
    Answered on December 15, 2014 at 10:04 AM

    Don't forget the <?php opening and ? closing PHP tags. I have updated the codes, please get it here: http://pastiebin.com/548ef8391062d. Save this as a PHP file and use it as your custom thank you page. 

    Thanks

     

     

  • Profile Image
    bltrecruiting
    Answered on December 15, 2014 at 10:16 AM

    Thank you for adding those in.

     

    I have tried to re-run the custom php thank you page and I still just get the code on the screen......but now with the added thank you text. Is this normal or am I doing something silly?

     

    Many thank for your help on this it's stressing me a little now. 

     

     

  • Profile Image
    Welvin
    Answered on December 15, 2014 at 11:47 AM

    I have just tried the codes here and it's working fine. Although there's an error connecting to your Database:

    Kindly correct the details and try it again.

    Here's the complete PHP Codes: https://shots.jotform.com/welvin/php/thankyou.textile.

    Thank you!