Card expiration date: Months are not translated in French

  • Profile Image
    asccombaillaux
    Asked on November 27, 2014 at 08:12 PM
    I use french version of JotForm builder and the months of the expiration date are not translated at execution time, although they are at edition time.
  • Profile Image
    Jan
    Answered on November 27, 2014 at 09:11 PM

    Hi,

    Please try to make sure French as the default language.

    1. On the Setup & Embed, click "Languages" button.

    2. On the Multi-language form options, click "+Add New" button.

    3. After selecting your chosen language, this window will appear. Click the red balloon with exclamation point.

    4. Check and make sure that the months are translated properly. Click Save

     

    5. Click the selected language and make sure to set it as default. Click Save.

     

    Hope this helps. If not, let us know so we can further investigate. 

    Thanks!

  • Profile Image
    asccombaillaux
    Answered on November 28, 2014 at 06:15 AM

    Hi,

    I am alreday with french as default language for my account and it's kept as the default when I am creating a new form from scratch keeping the same error.

    Probably I missed something initillay when switching to frnech as I had a warning telling me "not everything has been translated" and I choose "ignore".

    In order to get rid of the country flag I kept only frenc language so here is my language confirguration:

    If i am clicking on the option button the only screen i goy is:

    So there is no room for translation.

    I do not how to get back to the right tracks.

    Thanks for your help,

    Georges

     

  • Profile Image
    KadeJM
    Answered on November 28, 2014 at 11:08 AM

    It seems you are still having an issue with this that so far I'm unable to replicate on my end either.

    If possible can you please take a screenshot of what you are seeing as the problem on your end so that we can get a better understanding about this issue? You may use our Image Insertion Tool and our repository if you need it.

  • Profile Image
    Georges
    Answered on November 28, 2014 at 12:08 PM

    Hi,

    Here my form: http://form.jotformeu.com/form/43115732308347

    And the requested screen capture:

     

    I hope this will help you.

    Georges

  • Profile Image
    raul
    Answered on November 28, 2014 at 02:15 PM

    Thank you for providing the additional information.
    I was able to reproduce the issue.

    I went ahead and re-saved your translations in your form and was able to see the month names in French.

    Could you please check on your side and see if it works?
    Thanks.

  • Profile Image
    asccombaillaux
    Answered on November 29, 2014 at 12:26 PM

    HI,

    It is working propoerly now, but I have 2 other forms and the prblem will probably appear for any new one so can you give me the instrcutions so tahta I would be able to fix it myself.

    The two forms which need to be fixed are:

    http://form.jotformeu.com/form/43115757322350

    http://form.jotformeu.com/form/43115720245344

    Thanks for your help,

    Best Regards,

    Georges

  • Profile Image
    jonathan
    Answered on November 29, 2014 at 06:40 PM

    Hi Georges,

    The instructions had already been provided by our colleague previously.

    1. On the Setup & Embed, click "Languages" button.

    2. On the Multi-language form options, click "+Add New" button.

    3. After selecting your chosen language, this window will appear. Click the red balloon with exclamation point.

    4. Check and make sure that the months are translated properly. Click Save

     

    5. Click the selected language and make sure to set it as default. Click Save.

     

    I created a numbered screenshot of the steps also on how to

     

     

     

    Please tell us if you encounter any difficulty following the steps and adding the translation to your jotform.

    Thanks.

  • Profile Image
    asccombaillaux
    Answered on November 30, 2014 at 10:23 AM

    Hi Jonathan,

    I tried the solution proposed by Jan, but as emntionned earlier when entering the language options I do not get the menu tranlation but radio buttons which do not adress the issue. see attache image:

    Eventually Raul has been able to fix my initial payment form http://form.jotformeu.com/form/43115732308347

    But I still have 2 payment form which need to be fixed and for wich I cannot apply the proposed solution: These forms are:

     

    http://form.jotformeu.com/form/43115757322350

     

    http://form.jotformeu.com/form/43115720245344

     

    I think it has something to do with my account as when trying to create a brand new payment form I having the same issui:

    http://form.jotformeu.com/form/43333834566358

    I desabled the multi-language in my account.

    Thanks for your help,

    Georges

     

  • Profile Image
    Shadae
    Answered on November 30, 2014 at 03:30 PM

    Hi Georges,

    Unfortunately we are not able to see the screenshot that was provide. Can you please try to provide us with that again?

    How to Add a Screenshot to your post.

    Thank you.

  • Profile Image
    asccombaillaux
    Answered on December 01, 2014 at 09:57 AM

    Hi Shadae,

    Thanks for your help, my problem is fixed now as I "Cloned" the form which as been fixed by Rual, so could can consider this thread as closed.

    Thanks to the whole support team.

    Regards,

    Georges

  • Profile Image
    jonathan
    Answered on December 01, 2014 at 10:37 AM

    Hi Georges,

    Thank you for taking the time to update us on this.

    Contact us again anytime for any assistance you need with JotForm.

     

    Best