What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Submit button disappers on website

    Asked by xyz911 on November 30, 2014 at 11:52 AM

    Hi All,

    I have a very strange problem whit my form. The submit button disappears sometimes, and when I re-save the form in the backend, the submit comes back. It seems that the content at the last line disappears. When I put the submit button on the same line with another item(text area), they both disappear. When I re-open the form and click done( I think it's re-save action ) , They come back! So I think it's something wrong with the last line in the form?

    So Is there someone who can help me please?     

     

    Thank you!

    Page URL:
    http://www.realinshanghai.com/application/

    problem content backend same line submit
  • Profile Image
    JotForm Support

    Answered by Kiran on November 30, 2014 at 02:22 PM

    I see that the submit button is being displayed on the website now.

    If this issue seems to happen only on your system, I request you to clear the browser cache by following the guide below and check if the issue is resolved.

    http://www.wikihow.com/Clear-Your-Browser%27s-Cache 

    If it happens on other systems also, please try embedding the JotForm using iframe method and see if the issue is resolved. I've also cleared the form cache from our end to check if that helps.

    Let us know if the issue still persists. We will be happy to look into this issue further.

    Thank you!

  • Profile Image

    Answered by xyz911 on December 01, 2014 at 01:11 AM

    Hi Kiran, it doesn't display now, on my macbook with safari and Chrome and on windows 7 with IE, it's the same.

     

  • Profile Image
    JotForm Support

    Answered by Kiran on December 01, 2014 at 01:31 AM

    I notice that you are using WordPress for your website. I see that this issue is being caused due to height issues of the part where JotForm is embedded. When we check the JotForm using direct URL, it seems to be working fine.  

    http://www.jotform.com/form/43013728771454?

    Could you try embedding the JotForm using JotForm oembed WordPress plugin to see if the issue is resolved?

    https://wordpress.org/plugins/jotform-oembed/installation/ 

    Let us know if the issue still persists. We will be happy to look into this issue further.

    Thank you!

  • Profile Image

    Answered by xyz911 on December 01, 2014 at 01:57 AM

    I will try it 

  • Profile Image

    Answered by xyz911 on December 01, 2014 at 02:07 AM

    I intalled the  JotForm oembed, and do it with the instruction, but the url doesn't become the form....

  • Profile Image

    Answered by xyz911 on December 01, 2014 at 02:53 AM

    Hi Kiran, I embedded it successfully, so it works, but not very perfect, is there some solutions for that?

  • Profile Image
    JotForm Support

    Answered by Charlie on December 01, 2014 at 08:30 AM

    Hi,

    Upon checking the website link that you have, the form seems to be embedded correctly and the submit button seems to be working fine? You could also try using different embed code, we have an article that might help you on that, please visit this link: Which Embed Form Code to Use?

    This is the Embed Form Wizard that we have on the form builder:

     

    I hope this helps. Let us know if you need further assistance on this.

    Thank you.

  • Profile Image

    Answered by xyz911 on December 01, 2014 at 08:53 AM

    Thank you Charlie, it works well now! 

  • Profile Image
    JotForm Support

    Answered by Charlie on December 01, 2014 at 10:13 AM

    You're most welcome. I'm glad everything is working fine now.

    If you need an assistance again or have any other concerns, please feel free to open up a new thread here in the forum, we'll be more than happy to help you.

    Thank you.