What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Wordpress Embed: Payment Form Does not Calculate Totals When viewing from Ipad or Iphone

    Asked by dbcarr34 on December 01, 2014 at 02:41 PM

    Hello,

    I notice the payment form does not calculate totals when viewing from an ipad or iphone.  Any suggestions?

    Thanks,

    Dennis

    Page URL:
    https://www.mobilewirx.com/form/

    payment form ipad wordpress embed
  • Profile Image
    JotForm Support

    Answered by Kiran on December 01, 2014 at 03:08 PM

    I've checked the website using Google Chrome and Firefox and I notice that the calculation is not working while it is embedded on the website.

    However when viewed using the direct JotForm URL, the calculation is working fine.

    It seems that there is a conflict with other scripts on the website. Could you try re-embedding the JotForm on your website using our JotForm oembed plugin :

    https://wordpress.org/plugins/jotform-oembed/ 

    Let us know if the issue still persists. We will be happy to look into this issue further.

    Thank you!

  • Profile Image

    Answered by dbcarr34 on December 09, 2014 at 01:41 AM

    Hello Kiran,

    The JotForm plug in was installed and is now integrated on the website.

    What's interesting is that I used and iphone simulators to check and see if the totals were populating. Initially, it was working.  

    I then tried my iphone 5 about 6 times, and the totals were not calculating.  I cleared cache/cookies and tried again 2 times.  It still did not worked.  I then reloaded the page, and it worked.  I then tried 5 more times and it did not work.  

    Next, I went back to the iphone simulators online . . . it is not working . . . i tried many times with no success.  

    Any ideas?

    Thanks,

    Dennis

  • Profile Image
    JotForm Support

    Answered by Charlie on December 09, 2014 at 08:22 AM

    Hi Dennis,

    Upon checking your website, the total field doesn't seem to work in my end, even in desktop or PC view.

    In my console log, I that there are conflicts in your scripts and other codes. The oembed plugin seems to be blocked because your website loads in https or in secure protocol.

    I'll escalate this to our developers so that they can take a closer look. We'll get a notification from them when an update has been made.

    Here's a screenshot of the errors:

     

    For the meantime, please do try our other embed form code. You can find a guide here: http://www.jotform.com/help/67-Which-Form-Embed-Code-Should-I-Use

     

    I hope this helps. Please do get back to us when the other embed code worked.

    Thank you.

  • Profile Image

    Answered by dbcarr34 on December 09, 2014 at 10:20 PM

    Thanks for looking into this.

    My site needs to be https.  I have been using the secure (https) word press embed code.  It has worked fine without the jotform plug in, with the exception of IOS operating system.  As you requested, for testing purposes, I tried http version and the payment form did not appear at all.  

    The payment form seems to be working on my laptop again; the only thing I did reload the https embed code. However, it is still not working on the iphone, which was the whole reason for installing the plug in.  

    Do you have any more information on your end regarding this issue from the engineers?

  • Profile Image
    JotForm Support

    Answered by ashwin_d on December 10, 2014 at 07:27 AM

    Hello Dennis,

    http version of your form will not work if you embed it in your SSL web site. Please be noted that non secure content cannot be displayed in a secure web page. That is the reason why your form was not displayed with non secure embed code.

    My colleague have already reported this issue to our back end team. Unfortunately we have not received an update from our back end team yet. Upon checking the ticket status, I found that one of our developer is already looking into this issue. We will get back to you as soon as we have any update from them.

    Thank you!

  • Profile Image

    Answered by dbcarr34 on December 10, 2014 at 10:30 PM

    Hello Ashwin,

    Thanks for your response.  I will await your response.  Here are a couple of screenshots if you want to confirm the embed link and plug in:

    http://awesomescreenshot.com/01540dqj73

    http://awesomescreenshot.com/0f640dqmd1

    Regards,

    Dennis

     

     

  • Profile Image
    JotForm Support

    Answered by ashwin_d on December 10, 2014 at 11:46 PM

    Hello Dennis,

    Thank you for the screenshots you have shared.

    Lets wait for the response from our back end team.

    Thank you!

  • Profile Image
    JotForm Support

    Answered by paulsimpson on December 17, 2014 at 03:12 AM

    Hi,

    It looks like you also have our JotForm Feedback Button plugin installed. Can you update to the latest version of this plugin please to fix any incompatibility issues.

    I have tested our form embed in Wordpress on iphone and ipad and cannot replicate the problem you are having on your website which leads me to believe there is some incompatibility issue with some of your other plugins.

    I see there is a jmpress error on the developers console so it may be something to do with that. Can you deactivate all unused plugins and update to the latest version of all plugins you have activated.

    If that does not help can you give me a list of the plugins you have installed.

    Thanks

  • Profile Image

    Answered by dbcarr34 on December 17, 2014 at 08:17 AM

    Hello,

    Thanks for attempting to help.

    I just viewed the form on my iphone and the totals are still not calculating.  You indicate that the totals were calculating for you?

    I have updated the feedback plug in, and deactivated the aksimet plug in.  There are no other plug in issues.

    *Note:  This form is behaving exactly as it was before without the jotform plug in.  I installed the plug in after advice from jotform that dong so would make the calculations work when viewing from iphone/ipad ios.

  • Profile Image
    JotForm Support

    Answered by ashwin_d on December 17, 2014 at 09:32 AM

    Hello dbcarr34,

    Your message has reached my colleague @paulsimpson. He will get back to you as soon as he is available online.

    Thank you!

  • Profile Image

    Answered by dbcarr34 on December 24, 2014 at 10:31 AM

    Hello,

    Is there anyone who might be able to investigate this further?  It has been quite awhile since I have heard from anyone.  If this is not something you are interested in resolving, or it is not a high priority, please let me know.  I can give my website admin info.  It has to be something very simple.  Or, can you recommend someone/somewhere I can go to pay someone to find out why the form is not working on ipad/iphone.

    I know it is something simple because a couple of weeks ago it actually worked briefly on the iphone. I cannot remember if that was before or after installing the plug in.  It is not working now with the plug in installed.

    Thank you--

    Dennis

  • Profile Image
    JotForm Support

    Answered by Charlie on December 24, 2014 at 10:55 AM

    Hi Dennis,

    Apologies for the trouble. Upon checking your screenshots, I see that you have a lot of plugins activated. JotForm Embed Forms, JotForm Integration and JotForm oEmbed, if I'm not mistaken, they function all the same. Can you please deactivate all of them and try using them one by one. I see in our Apps page that this is the latest Wordpress plugin support that we have, http://apps.jotform.com/app/wordpress_embed_form. After that, please do try re-embedding the form using each plugins own method. 

    I also see that this concern is still open and being monitored by our back end team. We will receive an update from them if they found the culprit to this problem.

    Thank you.

     

  • Profile Image

    Answered by dbcarr34 on December 25, 2014 at 02:28 PM

    Hello,

    I deactivated all plug ins and it tested.  It worked on my iphone (calculations worked).  I then deleted all plug ins.  I tried again on iphone.  It did not work.  I reloaded page on phone, and it worked again.  Not sure what is going on . . .  I reloaded page again, and it worked.

    Will keep you posted-thanks.

    Dennis

    P.S.  I don't know CSS and your awesome team helped me out with building this page.  I have some modifications that need to be done and will need to do so in the future.  I there is someone on your team
    that I could hire to make changes when I need to, I'd sure be interested in discussing this.  Attached is the latest draft of changes I need done.  I just put an add on Elance for this purpose, yet I'd prefer to work with your team.
  • Profile Image

    Answered by Ben on December 25, 2014 at 02:44 PM

    Hi Dennis,

    In regards to the issue discussed here.

    I see that the issue is caused by the jmpress script for infinite canvas. It breaks at the start of the loading causing the jotform to load improperly as well as probably some other things on your website.

    What I would suggest is to have the iframe embed code on your website instead of js:

    Current:

    <script type="text/javascript" src="https://secure.jotform.us/jsform/43206494128151"></script>

    Suggested:

    <iframe id="43206494128151" frameborder="0" scrolling="no" style="width: 100%; border: medium none; height: 4342px;" name="43206494128151" allowtransparency="true" src="https://secure.jotform.us/form/43206494128151"></iframe>

    Please let us know how that goes for you.

    In regards to the second part of your question, I have moved it into its own separate thread here: http://www.jotform.com/answers/482240 so that we can avoid any confusions and help you resolve this properly.

    Best Regards,
    Ben

  • Profile Image

    Answered by dbcarr34 on December 26, 2014 at 06:33 PM

    Ok, very good.  I used your iframe code above and replaced with new form #.  

  • Profile Image
    JotForm Support

    Answered by Charlie on December 26, 2014 at 08:21 PM

    In behalf of my colleagues, you are most welcome. Did the iFrame code solved the problem? Remember to use only one embed form method at a time, remove or deactivate plugins that are not used that does the same embedding to avoid conflicts.

    Let us know if you needed help.

    Thank you.