What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Show My Weather Widget Prevents Form Submission. Problem Started 2 Days Ago.

    Asked by cnaleid on December 02, 2014 at 07:06 PM

    Are your servers maxed out over the holiday or what I've had no issues previous but this doesn't work!

    Page URL:
    {\rtf1\ansi\ansicpg1252{\fonttbl\f0\fswiss\fcharset0Helvetica;}{\color<br/>tbl;\red255\green255\blue255;\red0\green0\blue0;\red255\green255\blue2<br/>55;}\d

    Show My Weather widget bug prevents submission prevents submissions stops submission stops submissions widget problem
  • Profile Image
    JotForm Support

    Answered by Welvin on December 02, 2014 at 07:41 PM

    Hi,

    When you say it's failed, meaning, your users are not able to submit to the form? If so, then maybe there's something wrong with the form or the way how you embed it is incorrect or something is missing. Please kindly correct the page URL so we can check further. 

    Also try to re-embed your form using our iFrame method: http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code.

    Thank you!

     

  • Profile Image

    Answered by cnaleid on December 02, 2014 at 07:53 PM

    http://form.jotform.us/form/41375918100147

    yes users are not able to submit with nothing having changed with the form.

  • Profile Image
    JotForm Support

    Answered by abajan on December 02, 2014 at 08:11 PM

    Is it possible users didn't see the submit button because it's so far below the "last" field? It's just a hunch. Initially, I myself thought there was no such button on the form. I put "last" in inverted commas because upon cloning the jotform I discovered two Show My Weather widgets which are not visible at the form's URL. Upon opening each widget, I discovered why they aren't displaying any info at the URL. Abbreviations have been used for the state name instead of the full name. In each widget, replace NH with New Hampshire and save the jotform.

  • Profile Image

    Answered by cnaleid on December 02, 2014 at 08:15 PM

    We have four users who use this each day nothing has changed other than the submittal not going through.

  • Profile Image

    Answered by cnaleid on December 02, 2014 at 08:29 PM

    I eliminated the dead weather widgets (which must have been in place for two months and I never new they were their) and the form went through, hopefully this is a permanent fix not a late in the day past heavy traffic fix. Can't say enough about jotform customer service working to solve individual issues quickly. Thank you!

  • Profile Image
    JotForm Support

    Answered by Welvin on December 02, 2014 at 08:38 PM

    I think the widget is causing the problem. If you need it, you can add it back to the form but make sure to add the full name of the state as stated by my colleague.

    It's been our pleasure to help. If the issue persists, please let us know so we can check further. Also, you may consider my suggestion to re-embed the form using our iFrame method. Just in case the form is embedded to your website - to avoid possible script conflict.

    Thanks

  • Profile Image
    JotForm Support

    Answered by abajan on December 03, 2014 at 04:54 AM

    @cnaleid

    Thanks for notifying us that removing the widgets fixed the problem. I was able to replicate the issue in one of my own jotforms. This means it's a system-wide issue. Apparently, an update of some sort applied to the widget three days has caused this. A ticket has been submitted about the bug.

    Cheers