What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Account Over Qouta and accessing submissions

    Asked by bugwb_admin on December 09, 2014 at 10:57 PM

    It looks like i went over my form quota. I need to get to my forms. Please help me retrieve the data I have.

    I also clicked to upgrade but nothing happened. I need the data as soon as possible!

    Please help!

     

    My Forms retrieve
  • Profile Image
    JotForm Support

    Answered by Welvin on December 10, 2014 at 08:10 AM

    Hi,

    You should still be able to access your form submissions and download it even when you reach your account limits. Please try to logout from your account, clear your browsers cache and cookies for Jotform then login again. You should be able to see your forms back right after doing these steps. If not, please update this thread so we can further check.

    As for upgrading your account, please let us know if you want to subscribe to our next plan which is the Economy. Choose either Monthly, Yearly or Bi-Yearly and we'll change/do it to our end.

    Thanks

  • Profile Image

    Answered by bugwb_admin on December 10, 2014 at 09:42 AM

    Problem was solved but let me explain.

    There is clearly something wrong when it disables the forms. I shouldn't be locked out of seeing the forms or locked out of the account.

    When I went to login or upgrade neither worked. It wouldn't even let me login. It said the username or password didn't exist. I tried several times and double/triple/quadruple-checked to make certain I was typing the username, email or password correctly. When I tried resetting the password several times tt kept giving me the message that the username or email didn't exist.

    It was really by blind luck that I solved the problem. I went back to the email notification that informed me my forms were disabled and that I clicked on the link to upgrade (as I had already done). When I did that, I saw the tabs at the top. I clicked on MyForms but it didn't show anything. It went to the page but all the forms were gone. I thought, okay, I guess when they disable the forms I don't even get to see the collected data. That happened to me last night several times and it was extremely frustrating. It felt like I was begin forced to upgrade. I tried upgrading again and no luck. It said the process would take a few minutes but I waited hours and nothing changed.

    I then went back and clicked on the account tab on the upper right corner from the upgrade screen. When I did that, I could see that indeed it was logged in with my username, the same one that I had typed in several times. I thought maybe I should just change the password. Not sure why this would even have an affect at all but I tried it. It said password was changed successfully. Then I tried to login again and it worked and I could see the forms. Again, I checked the email and username and it was identical to the ones I had requested for password reset and it showed it was identical to what I had inputted.

    I hope you can duplicate the problem so you can find the glitch and fix it. It was extremely frustrating and I am now behind in my work because I could not access the data.

     

     

  • Profile Image

    Answered by bugwb_admin on December 10, 2014 at 09:45 AM

    ALSO, it still won't let me upgrade. I need to collect more forms so I need this to be fixed. HURRY PLEASE.

    I honestly feel I should get some kind of break or discount for all this trouble. I feel like I'm being punished for something being by forced to upgrade so I can collect more forms. I'm ALREADY a premium subscriber.

  • Profile Image

    Answered by val on December 10, 2014 at 12:22 PM

    Hi,

    I've checked your account and I see that your are a Premium User now, so if you have a problem accessing to your account, maybe you should try clearing your cache and cookies in your browsers like my colleague said, then close your browser, open back and try to log-in again.

    Please let us know if the problem still persist.

    Thanks.