form isn't working... "please refresh" shows up when submitted

  • Profile Image
    Adria
    Asked on September 30, 2011 at 11:09 AM

    I have a number of forms that all of the sudden aren't working.  When a user submits the form data, a page with "please refresh" appears.  I'm waiting to hear back from technical support as this is obviously a critical issue for all of my clients who use jot form for their online forms.  Help!

  • Profile Image
    JotFormHelper
    Answered on September 30, 2011 at 07:05 PM

    JotForm Will Help You Soon! - Sorry About The Delay!

    Thank You For Using JotForm

    (Im just a forum helper!) 

    -Y H

  • Profile Image
    mliz
    Answered on October 01, 2011 at 12:06 AM

    Hi there,

    I tested some of your forms but was unable to replicate the page with the error. Can you please send the url of the form which had the issue so that we can investigate and find out what might have been causing this behaviour?

    We'll await for your response.

  • Profile Image
    kritts
    Answered on December 30, 2011 at 09:43 PM

    I'm getting it with IE8 on WinXP over a good connection.  Works fine with Chrome, Safari, and Firefox.

    https://secure.jotform.com/form/13625015228 is my form.

     

    I tried adding the various jotform servers, including domain to "trusted sites" in IE's internet options, still get the "please refresh" error.

     

    Edit:  A buddy had tried it on a kindlefire, when IE went belly up, it gave a brief message that IE changed the page to stop cross-site scripting.  After that I set "trusted sites" security level to lowest on my WinXP IE8 PC, restarted IE, still no go.  

     

    http://v2.jotform.com/payment_submit.php is the page that pops up with the "please refresh". Note that this is on the old server!!!

  • Profile Image
    liyam
    Answered on December 31, 2011 at 02:25 AM

    Let me pass this issue to our development team.  They will respond to this as soon as they're available or if they have already fixed the issue.

    Thank you for your patience.

  • Profile Image
    liyam
    Answered on December 31, 2011 at 02:52 AM

    Update: I was able to find out something.  So far a bug occurs in IE 8 with having the close button in your form.  You might want to find another solution and remove the close button at the bottom of your form for now while this issue is being resolved.

  • Profile Image
    emrew86
    Answered on January 02, 2012 at 05:12 AM

    hi Adria, you have to remove your code which is written into Free Text (HTML)

  • Profile Image
    kritts
    Answered on January 02, 2012 at 09:25 PM

    Big thanks!  Removing the "close window" button appears to have fixed it. Kritts