What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form Does Not Display Correctly on Google Site

    Asked by contactform77 on December 29, 2014 at 12:21 PM

    Hi,

    the problem is the form sometimes it works and sometimes not. When I open my site, sometimes doesn't display the form and I don't understand why.

    I put the form following your instructions at this link http://www.jotform.com/help/19-Adding-Form-to-Google-Sites

    could you help me to solve the problem?

     

    many thanks in advance

    Page URL:
    http://www.sienarottami.com/contatti-email-telefono

    form doesn't work doesn't work does not display Google Site
  • Profile Image
    JotForm Support

    Answered by Charlie on December 29, 2014 at 01:15 PM

    Hi,

    I would just like to confirm, are you using Google Sites in running your website? You can check this guide that we have, Which Form Embed Code To Use, it might help you on what embed code to use. Can you please try re-embedding the code again? Also, if you can share a screenshot of how or where you embed your form that would help us a lot.

    We'll wait for your response.

    Thank you.

  • Profile Image

    Answered by kirksvillewebdesign on December 29, 2014 at 04:32 PM

    Yes, it's a Google Site. Your recommended embed method for Google Sites isn't working. Perhaps the XML gadget is bugged. 

  • Profile Image

    Answered by Ben on December 29, 2014 at 05:14 PM

    Hi @kirksvillewebdesign

    I see that you are posting on other people's posts in regards to this issue causing unnecessary confusion and giving link to a site where the jotform is shown.

    Please stop doing this in order for us to be able to help you if you need any assistance, but more importantly people that had opened their threads and might not get assistance as you have posted a link to a website where the jotforms are showing properly.

    @contactform77

    We have notified our developers of your issue and they will be checking your thread and all other threads opened on this issue and update you as soon as the issue is resolved.

    Best Regards,
    Ben

  • Profile Image

    Answered by kirksvillewebdesign on December 29, 2014 at 05:18 PM

    I am experiencing the same problem that they are. Therefore it is relevant. In the meantime, I have installed an iframe gadget on my site so that I can still do business.

    Sorry for the confusion, just trying to make ends meet here while I await the bug fix.

    Thanks for your prompt response to the issue, most appreciated.

  • Profile Image

    Answered by Ben on December 29, 2014 at 05:31 PM

    Hi @kirksvillewebdesign,

    I understand that it is closely connected, but as:

    1. it can cause confusion and
    2. seem that someone is no longer experiencing the issue described when they have opened a thread as well as
    3. allow us to see how many people are affected by this, while in the same time
    4. avoid thread hijacking.

    For these reasons I would suggest opening a new thread.

    That way we will raise the issue to our developers related to your own website and jotforms as well and allow our developers to check if your website is still experiencing the issue or not.

    To open a new thread please go here: http://www.jotform.com/contact/

    Thank you for your understanding towards the thread owners and us.

    Best Regards,
    Ben

  • Profile Image

    Answered by Ben on December 30, 2014 at 08:54 AM

    Hi @contactform77

    Our developers have notified us that this issue is resolved now.

    Please kindly check and let us know in case you are still experiencing the same.

    Best Regards,
    Ben

  • Profile Image

    Answered by contactform77 on January 04, 2015 at 04:32 AM

    Hi Ben,

    The form is working now,

    Many thanks

  • Profile Image

    Answered by Ben on January 04, 2015 at 10:24 AM

    Hi,

    Great. Thank you for updating us.

    Please feel free to let us now in case you have any further questions and we would be happy to assist.

    Best Regards,
    Ben