Revision History cannot properly restore a styled form

  • Profile Image
    Elevation180
    Asked on December 30, 2014 at 01:51 PM

    My form is not showing up correctly anymore

    I made a bunch of CSS changes to a theme from your theme store.  The form was showing correctly last night.

    This morning several (but not all) of the changes were no longer there.  When I looked at the revision history and went back one revision, it showed perfectly in the revision window:  http://www.jotform.com/myforms/rev/43435336121143/ver/54a2de1325d79063758b4568

    Just to be sure, I'm wanting the 7:28 update from yesterday to be the current version.  

    But when I look at the current version http://form.jotform.us/form/43435336121143  it is even worse than it was the first thing in the morning.  

    Why isn't this taking?  I really really want to make this work as I build marketing funnels for people and we do lots of quizzes for lead magnet.  I NEED for this to work.  Not only for this client but for all of my clients.  

    Thanks.  

  • Profile Image
    Mike
    Answered on December 30, 2014 at 02:50 PM

    Thank you for contacting us.

    I have checked our recent support forum threads, but I have not found any similar report from other users.

    Please try to restore the form using the 'Reverse to this version' button in Revision History tool to see how it goes with restoring.

    If you need any further assistance on this, please let us know. We will be happy to help.

  • Profile Image
    Ann 
    Answered on December 30, 2014 at 03:05 PM

    I did exactly that.  

    I clicked on Revision History; chose the correct version; clicked restore to this version; it says the revision was successful, I have a green box with correct version.  See here:  https://www.dropbox.com/s/cn6o02766j1sap0/Screenshot%202014-12-30%2014.59.48.png?dl=0

    Then I close out, click view form and see an earlier version.  See here:  https://www.dropbox.com/s/8qk1nuvjzkkzgu5/Screenshot%202014-12-30%2015.00.59.png?dl=0

    This earlier version is the exact format that the original theme I used has.  None of the CSS changes or even theme designer changes are there anymore.  

    Help!

  • Profile Image
    Mike
    Answered on December 30, 2014 at 03:58 PM

    We are sorry for the inconveniences caused.

    I have added the previous form styles to the Inject Custom CSS area on your form.

    Now you form looks as on the Revision History tool.

    It is probably that our new Themes are not yet fully optimized to work with the restoration tool. I have attached a bug report ticket and escalated it to our Development Team.