Unsafe elements alert when I see my form using HTTPS

  • Profile Image
    LMBShow
    Asked on January 03, 2015 at 09:07 PM

    my browser is warning me because of unsafe elements in the https form. pleas have a look. thank you.

  • Profile Image
    raul
    Answered on January 03, 2015 at 11:28 PM

    Could you please try to modify the first two lines of the CSS code of your form to the following:

    @import "https://fonts.googleapis.com/css?family=Pacifico|Rambla:light,lightitalic,normal,italic,bold,bolditalic";

    @import "https://secure.jotform.com/themes/css/buttons/form-submit-button-blue.css";

     

    And see if it helps?

    Also, please note that since you're using a FREE account you're only allowed to accept 10 SSL submissions in your form which mean that you might need to consider using the non-secure version of your form instead.

    Let us know if this helps.
    Thank you.

  • Profile Image
    LMBShow
    Answered on January 04, 2015 at 09:41 AM

    Sorry it doesn’t help. Same Problem.

     

    Btw: I think, I will take the paid forms after a successful test ;)

  • Profile Image
    Jeanette
    Answered on January 04, 2015 at 03:02 PM

    There was still an un-secure link reference on your CSS code:

    "http://german.jotform.com/themes/css/buttons/form-submit-button-blue.css";

    So, I've changed it to https://

    "https://german.jotform.com/themes/css/buttons/form-submit-button-blue.css";

  • Profile Image
    LMBShow
    Answered on January 04, 2015 at 05:17 PM

    sorry, i can't see it. did you fix it in my form?

     

    the problem is not gone.

    could it be the google api?

  • Profile Image
    jonathan
    Answered on January 04, 2015 at 07:09 PM

    Hi,

    When I checked your jotform https://secure.jotformeu.com/form/50006925234346 source code, I was able to see a non secure http that belongs to google api font.

    See image below

     

     

    aside from this, I could not reproduced the browser issue though. I also checked using Firefox and Chrome browser, but it did not give the non-secure alert

     

     

    I suggest correcting the remaining http and test again.

    Please let us know if issue persist.

    Thanks.

     

  • Profile Image
    LMBShow
    Answered on January 04, 2015 at 07:37 PM

    i've already seen the http in the https form, but i can't find it within the formular builder.

     

    I also get the closed lock, but left beside this there is a warning because of blocked unsecure elements. you have this in your screenshot too.

    Try it in internet explorer, ther you get a popup message.

  • Profile Image
    ashwin_d
    Answered on January 05, 2015 at 04:31 AM

    Hello LMBShow,

    I did check your form and I am able to replicate the issue you are having. The following css import code is added in your form dynamically :

    @import url(http://fonts.googleapis.com/css?family=Dancing+Script:400,700);  

    Please check the screenshot below:

    I am not sure but the issue seems to be related to submit button and form theme. Let me report it to our back end team. We will get back to you as soon as we have any update from them. 

    Thank you!

  • Profile Image
    snaplash
    Answered on December 27, 2016 at 10:26 PM

    I am having the same issue - is there a fix for the generated code for supernova to https?
  • Profile Image
    ashwin_d
    Answered on December 28, 2016 at 01:08 AM

    Hello snaplash,

    I have moved your question to a new thread so that we can address your issue separately. You will be answered here:  https://www.jotform.com/answers/1020279

    Thank you!

  • Profile Image
    EltonCris
    Answered on December 28, 2016 at 06:57 AM

    @LMBShow

    I am the author of the wedding theme you're using. Apologies for the oversight on this.

    Anyway, we have fixed the unsecured font URL on the wedding theme. Feel free to re-apply the theme in your form to get the latest update. This should fix the problem.

    https://www.jotform.com/theme-store/theme/lovely-wedding

    Thanks!