Emails are not being sent to all addresses after clicking on Test Email button

  • Profile Image
    crussell
    Asked on January 05, 2015 at 04:37 PM

    My form SUBMIT button properties keep reverting back to only my email address (account holder).

     

    It is not keeping additional recipients emails even with a comma and a space between addresses?

     

    Please advise? (screen shot instructions aren't working...I followed the instructions but no one else is receiving the test emails.)

     

    Thank You,

    Cindy Russell/Eagle Granite

  • Profile Image
    Ben
    Answered on January 05, 2015 at 04:47 PM

    Hi Cindy,

    There are many reasons why our system only sends test emails to the email of the account holder:

    1. these are test emails so they should be sent to only 1 person that is expecting them
    2. sending to non-account holders email address would be misused for sending spam emails
    3. isolating the probable issues that might affect emails to not be received

    There are only 3 that I could tell you off of my head.

    Now what you should do to test it is to make a submission on your jotform instead. This way you are testing the conditions and all other parts of the jotform and test if the emails are properly sent to everyone on the list.

    You of course do this after checking everything over Test Email and confirming that it should be OK.

    Do let us know how it goes and if you have any further questions.

    Best Regards,
    Ben