Why the FTP integration is not working any more?

  • Profile Image
    BlackSwanArts
    Asked on January 12, 2015 at 06:42 PM

    I think the issue was down to FTP integration I had set up.  We had a malware attack on our CMS in December (which is now all clear) and maybe it caused a problem then.

    I have got Dropbox integration working, but what I don't understand is why I can't re set up the FTP integration.  The 'Test Connection' says all is fine, but then it just hangs when I go to choose a folder.

    Any thoughts?

  • Profile Image
    raul
    Answered on January 12, 2015 at 07:27 PM

    If I understand correctly, you were using a Dropbox integration and also had FTP enabled in your form and your Dropbox integration is working but not the FTP. Is that correct?

    Have you tried to manually upload a file in your FTP server using a client like FileZilla? Since you mention that your server suffered a malware attack then your IT personnel could have changed some security settings in it to make it more secure.

    Please give a try and let us know if you're able to upload a testing file in your server.
    Thank you.

  • Profile Image
    BlackSwanArts
    Answered on January 12, 2015 at 07:50 PM

    FTP & Dropbox were working before.  Now form doesn't work when i implement FTP integration - it just hangs.  I can FTP to the site fine using FileZilla.

  • Profile Image
    BlackSwanArts
    Answered on January 12, 2015 at 07:51 PM

    N.B. Test Connection is fine.  it's just at the folder stage that it hangs during setup, and then on submit with the form leading to the error:
    Upload Error
    File could not be uploaded for some reason.
    Please go back and fix the problem(s)

    Would welcome any thoughts you have on the matter

  • Profile Image
    jonathan
    Answered on January 12, 2015 at 09:09 PM

    Hi,

    It is possible that the upload path/folder that you have assigned for the FTP does not have the sufficient write permission also.

    I have just test the form submission FTP integration , and I was able to successfully integrate just fine.

    Check if the folder/path have the 'write permission'

     

     

    Inform us if still not resolved.

    Thanks.

  • Profile Image
    BlackSwanArts
    Answered on January 13, 2015 at 05:17 AM

    Sorry - but still not resolved.  Thanks for your suggestions above, but this is what I have been doing and remember this was all set up and working fine last year (no changes in write permissions).  Right now neither the Dropbox or the FTP integrations are working.

  • Profile Image
    BlackSwanArts
    Answered on January 13, 2015 at 06:03 AM

    I have managed to resolve the FTP integration on the 'Clone' version of the form, but alas the Dropbox integration is still not functioning.  I have double checked all settings - at a loss.
  • Profile Image
    Welvin
    Answered on January 13, 2015 at 08:46 AM

    Great to know that the FTP integration is now working. Since the original post was related to the FTP integration, I've moved your Dropbox problem to a new thread. Kindly check it here: http://www.jotform.com/answers/495077.

    Thanks