I cannot submit my form even when required fields are filled in

  • Profile Image
    taro10h
    Asked on January 13, 2015 at 07:24 AM

    I can't submit my form after filling all the require fields. Please check for me

    http://form.jotformpro.com/form/50118457563961?

  • Profile Image
    jonathan
    Answered on January 13, 2015 at 09:42 AM

    Hi,

    I was able to reproduced the problem. I also could not submit your jotform http://www.jotformpro.com/form/50118457563961 even when all filled up.

    It seems your form was corrupted already due to a lot of editions. Example, I see the conditional statements to have a lot of deletion that are not cleaned.

     

    I suggest clearing them first and refresh the form by saving again in your Form Builder.

    Hope this help. Let us know if issue remains.

    Thanks.

     

     

     

  • Profile Image
    taro10h
    Answered on January 13, 2015 at 10:12 AM

    Thanks again for the awesome support!

    I have just developed it today. Let's me clean it up!

    You guys rock!

  • Profile Image
    taro10h
    Answered on January 13, 2015 at 10:33 AM

    Hello again,

    I cleaned it up. But it still doesn't work. Pls check it out again for me

    I clone my form to create a sandbox form at this link, you can try to modify to debug

    http://form.jotformpro.com/form/50124716969966

  • Profile Image
    david
    Answered on January 13, 2015 at 11:48 AM

    Hi,

    I checked your form and it appears as though when you cloned the item entry sections they were cloned with bugged requirements.  Since a few fields were required in item 1, the form thinks those same fields are required with items 2-5.

    I went ahead and removed items 2-5, removed the requirements from the first item, them added everything back again.  Then I added the conditions back in.  Here my working clone of your form:

    http://form.jotformpro.com/form/50124246568959

    http://www.jotform.com/help/42-How-to-Clone-an-Existing-Form-from-a-URL

    You may need to go back through and set the fields you would like to be required, back to being required.  The form should work as expected though.

    Let us know if you have any further questions and we will be happy to help.

  • Profile Image
    taro10h
    Answered on January 13, 2015 at 12:17 PM

    Hi David,

    pls delete the form in your account. I dont want someone else to clone it. Thanks!

  • Profile Image
    david
    Answered on January 13, 2015 at 12:36 PM

    I deleted the form from my account as per your request.  Let us know if there is anything else we can help you with and we will be be happy to do so.