What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Create a form to test Image Upload Preview

    Asked by sunlakehoa on January 21, 2015 at 06:09 PM

    After clicking the Submit button, the Form was hung up with a "Please Wait" message

    Page URL:
    http://form.jotform.ca/form/50206673949260

    Screenshot
    upload preview
  • Profile Image
    JotForm Support

    Answered by EltonCris on January 21, 2015 at 07:43 PM

    Hi,

    It seems to be working fine on my end. I have tested it both IE10 and IE11.

    Do you have any specific steps on how to reproduce the problem? Or what browser version are you using? I would also suggest to clear your browser's cache and try it again. See if this helps.

    Thanks!

  • Profile Image

    Answered by sunlakehoa on January 22, 2015 at 12:13 PM

    Thanks for your help

    I just created the form to test the Image Upload Widget. After filling in the data and clicking the submit button, it changes to Please Wait & did not get to the Thank You page.  The data was not submitted. Tried it both on Win7/ IE 11 & Win 7/Chrome 39

    The reason to setup this test was that the widget was working off and on (unstable) on another test form using various platform (Win 7 & 8 on IE & Chrome, firefox, IOS safari on ipad & iphone & Samsung TAb4 native browser & Chrome). In reading some of the help from others with similar issues, I decided to clear the cache from my IE and Chrome.  It seems after that, the widget did not work at all (failed to load the image on any platform from my form).

    So far, my results was very unreliable in using this widget.

    Any help is appreciated

  • Profile Image
    JotForm Support

    Answered by david on January 22, 2015 at 03:00 PM

    Hi,

    I checked your form in IE, Chrome and FireFox, the widget appears to be working fine in all 3:

    I did, however, need to to refresh IE several times before the widget would show up.

    Try refreshing the page if the widget does not load.  After loading once in IE it was fine from then on out.