What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Unable to clone form even if the privacy setting allows form cloning.

    Asked by raypryor3 on January 23, 2015 at 02:15 AM

    Hi, in Account > Settings > Privacy I have the box unchecked which should allow my forms to be cloned but when I try to "Import from a webpage" and enter a working form URL, Jotform gives me the error: "No form found on the page. Please check the source code you provided".

     

    I turn this setting off and on from time to time but the privacy seems to be stuck on "off"

     

    Any ideas? Thanks in advance.

  • Profile Image
    JotForm Support

    Answered by ashwin_d on January 23, 2015 at 09:44 AM

    Hello raypryor3,

    I'm sorry for the trouble caused to you.

    I did check your account privacy setting and the form cloning seems to be allowed. I did try to clone one of your form and I was able to do that successfully in my support as well as free account. Please check the screenshot below:

     

    Let me report this issue to our back end team. We will get back to you as soon as we have any update form them.

    In which account you are trying to clone your form? Please try to sign out and then sign in again before cloning form in destination account and see if that helps you.

    Thank you!

  • Profile Image

    Answered by raypryor3 on January 23, 2015 at 02:41 PM

    Hi Ashwin, thanks for the reply. I see the screenshot but the strange this that I cannot clone this form. I just created a new free account and it doesn't work there either.

     

    - The accounts you tried this from, where they new?

    - I'm trying to import this into an account named kellyrobertson

     

    Thanks

  • Profile Image

    Answered by raypryor3 on January 23, 2015 at 02:54 PM

    Ok, so after looking at the other threads on this, it looks like this is an issue that support is not able to reproduce, but many users are obviously having the same problem.

     

    - Can you someone in support try and reproduce this from a domain outside of jotform support? Maybe your home connection or your phone? I tried from my laptop and phone with no luck.

     

    - BTW, the clone function was working perfectly before a couple days ago. Did something change on the backend over the last couple of days?

     

    - I am in the US

     

    Thanks in advance for your help

  • Profile Image

    Answered by raypryor3 on January 23, 2015 at 03:01 PM

    This may have to do with the domains.

     

    When I click the Embed form wizard, I get a form URL in this format:

    - http://form.jotform.us/form/#######

    but in other support posts I've seen the URL in the format of:

    - http://www.jotform.us/form/####### ( note the www )

    and one has even had the format of:

    - http://www.jotform.me/form/  ( note the .me )

    Could this be the issue???

     

    It seems like the form URL works when you visit it directly, but it won't allow cloning.

     

     

  • Profile Image

    Answered by vmurphy on January 23, 2015 at 03:12 PM

    Having same problem. Digging further I see error 400 being returned from

    http://www.jotform.com/server.php

    and further checking shows:

    {"error":"Unauthorized request. You do not have access to this form","success":false,"duration":"0.029"}

    The form I'm trying to clone is:

    http://www.jotform.ca/form/50087058254253

  • Profile Image

    Answered by Shadae on January 23, 2015 at 05:09 PM

    Hi raypryor3,

    You should be able to clone the form using any of those URLs, as long as the user allows for the form to be cloned.

    This has been escalated to our second level support, it has also been given a priority of Very Important. Any update on this issue will be posted on this thread.

    @vmurphy,

    I have moved your post to a new thread: http://www.jotform.com/answers/502390

    It will be addressed there. 

    Thank you.

  • Profile Image
    JotForm Developer

    Answered by ceren on January 27, 2015 at 04:29 AM

    Hello,

    The problem about clone form feature is fixed. I've tested it with a non-support account and able to clone existing forms.

    We are truly sorry for any inconveniences caused.

    Regards.