Conditional statements not working

  • Profile Image
    drjax
    Asked on January 29, 2015 at 01:01 PM

    https://www.jotform.com//?formID=43386416869974

    There are four questions (yes/no) that are designed to show/hide a Notice.  Unfortunately, the Notice shows all the time, but should only show when any one of the four questions is answered "Yes."  I tried placing the condition that If Are you out of work due to your condition is equal to "No" then Hide Notice.  The problem is that if any one of the 4 questions response is "No" it doesn't matter if the other 3 are "Yes," the Notice is hidden. 

    So, what I get is either the Notice shows all the time or none of the time.  I only need it to show if any of the 4 questions are "Yes."  If all are "No" the notice should be hidden.  Need help.

  • Profile Image
    Mike
    Answered on January 29, 2015 at 02:30 PM

    Thank you for contacting us.

    So, what I get is either the Notice shows all the time or none of the time.  I only need it to show if any of the 4 questions are "Yes." 

    You can do this with a single Show condition. Please see the following animation:

    Form example:

    http://form.jotformpro.com/form/50285433763962

    If you need any further assistance, please let us know.

  • Profile Image
    drjax
    Answered on February 02, 2015 at 08:14 PM

    Made the changes.  Doesn't work.  Check it for yourself.

    https://secure.jotformpro.com/form/43386416869974

     

    Jack

  • Profile Image
    EltonCris
    Answered on February 03, 2015 at 01:01 AM

    Hi Jack,

    I checked your conditions and I can't seem to find a condition similar to what my colleague did.

    These are the conditions on your form that triggers the notice.

    For the first condition, shouldn't it be like this?

    Here's my cloned version: http://form.jotformpro.com/form/50330830155949?

    You can clone this form if you want to so you can check its conditions.

    Thanks!

  • Profile Image
    drjax
    Answered on February 19, 2015 at 08:03 PM

    https://secure.jotformpro.com/form/43386416869974

    Made changes again.  Ran the form through Preview and Open in new tab.  Checked No for each condition, but the NOTICE still showed when I opened the pdf Submission.  Please check it again and tell me what I've done wrong.

     

    Jack

  • Profile Image
    Shadae
    Answered on February 19, 2015 at 09:22 PM

    Hi Jack,

    I am currently seeing that you form conditions are now working as desired. We are happy to see that you could have that issue resolved.

    Unfortunately when the PDF for your form is generated, if you have the option to show text and headers, the conditions associated with them will not be applied.

    Please inform us if you need further assistance.

  • Profile Image
    drjax
    Answered on February 19, 2015 at 11:01 PM

    Can I selectively decide what text and headers to display in the pdf?

     

  • Profile Image
    Kiran
    Answered on February 20, 2015 at 08:56 AM

    Your question related to PDF submission is moved to a separate thread and shall be answered shortly.

    http://www.jotform.com/answers/519564

    Thank you!