Masked Input Widget Not Showing Suffix and Prefix Set When Decimal/Thousandths Separator is Not Use or Blank

  • Profile Image
    oerez
    Asked on January 30, 2015 at 12:59 PM

    I am struggling with two issues with Masked Input Widget:

     

    1.) I would like a field that simply has a percentage.  This would be up to three digits and a % symbol as a suffix.  Bug: The suffix % symbol does not show up if I leave the decimal separator empty.  If I put the decimal separator in the suffix % symbol shows up, but so does the decimal, which is not needed/confusing when I don't need anything after the decimal.

     

    2.) I cannot control the format of the masked input widget (font, color, box) with CSS.  When clicking on the form box in the CSS editor, it creates a blank entry.  Tried to inspect source to see if I could identify the name, but I can't seem to do so. This means that the masked widgets look different than my other fields, and I need granular control.

    Also, masked input doesn't let me have hover text, so I can't really provide extended instructions, which I want to do.   

    Please advise.  Or if there are alternatives to masked widget that allow for properly labeled $ and % entries (of variable amounts) with number separators (,) and with full CSS control, and hover text, I'd use that instead.

     

    Thank You.

  • Profile Image
    Charlie
    Answered on January 30, 2015 at 02:51 PM

    Hi,

    It seems that this widget has limits on it. I would suggest that you use plain text box and add a masked input on it, in that way you'll have more options on it like adding hover text, CSS styling, adding conditions on it, etc...

     

     

    For the meantime, I'll escalate the bug regarding the removal of decimal separator not showing the suffix set. We'll hear from the developers when they have fixed the problem.

    For the other question that you have, I've opened another thread for that so that we can assist you better, it seems more appropriate as it is more related to CSS styling on a widget. You can refer to this link for that: http://www.jotform.com/answers/506943

    Kind regards.

  • Profile Image
    oerez
    Answered on January 30, 2015 at 09:14 PM

    Thank you!

  • Profile Image
    Jan
    Answered on January 31, 2015 at 01:52 AM

    On behalf of Charlie, you are welcome. We will update you via this thread once an update from our developers become available.

    Thank you for your patience.

  • Profile Image
    devgbk
    Answered on February 24, 2015 at 06:54 AM

    Hello,

    I'd like to inform you that the issue was fixed. Please check it and let us know if you have any other questions or concerns. 

    Thank you!