What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Unable to Translate Text fields and other previously saved translations are lost

    Asked by Colorapps on February 03, 2015 at 10:50 AM

    Hello,

     

    I have been working on a form, and I want to show a switch at the top of the page with  Spanish and English languages , so the customers can easily change the language. At the beginning, when I started working with the form, I tried to translate things from Spanish to english using the tool in the preferences panel  for the form, and it worked fine.

    Now, I have almost finish the form, and I was trying to finish all the translation also, but it doesn't work. I am able to work with the translation tool, but all the changes I do doesn't save correctly. When I reopen the translated language, for example English, all changes I have done before are lost.

    The form hasn't been published yet, so I can't give you the URL demanded above.

    Which could b e the problem?

    Thanks.

    translations doesn't work translation problem thanks tool
  • Profile Image

    Answered by stbkruse on February 03, 2015 at 10:54 AM

    I have the same problem here. Translated fields are not being saved properly.
  • Profile Image

    Answered by Colorapps on February 03, 2015 at 11:15 AM

    My form is  a cloned one, and I think it is something related to that, because on the original form it works perfectly.

    Unfortunately, I have done all my work on the cloned one...

    Is there any way to fix this?

    Thank you.

  • Profile Image
    JotForm Support

    Answered by Charlie on February 03, 2015 at 01:34 PM

    Hi,

    It seems that there's temporary problem with the form language feature of the form builder, it seems that when a form is cloned in a non-English content the other languages does not seem to work properly. I'll escalate this to our developers so that they can take a closer look at the problem. We'll update you immediately when we hear any news.

    My apologies for the inconvenience.

    Kind regards.

     

     

  • Profile Image

    Answered by Colorapps on February 05, 2015 at 04:39 AM

    Ok, thank you.

     

    I hope you can solve it as soon as possible.

  • Profile Image
    JotForm Support

    Answered by Charlie on February 05, 2015 at 08:19 AM

    Hi,

    Upon checking the ticket it seems that the back end team has already resolved the issue. Could you try adding the translations again and save each changes to see if it works as expected. We'll wait for your response.

    Thank you.

  • Profile Image

    Answered by stbkruse on February 05, 2015 at 09:10 AM

    That's interesting. If I have saved all the translations the Multilanguage tool still shows exclamation marks for missing translations but in the actual form (preview) the translation works.

    So the translation is being saved but it does not appear this way.

  • Profile Image
    JotForm Support

    Answered by Charlie on February 05, 2015 at 10:26 AM

    Hi @stbkruse,

    Thanks for sharing your that information. I see that you also have a separate thread here with the same issue. You could reply on that thread and we will assist you from there.

    Thank you.

  • Profile Image

    Answered by Colorapps on February 11, 2015 at 06:02 AM

    Hello again,

     

    unfortunatelly, it doens't work for me. Now the English language appears as the default one, and I also have the Spanish but none of them can be edited.  Furthermore, when I preview the form on the browser, the languange tab appear at the top, where it is fixed, but it can't be opened.

    Thanks.

     

  • Profile Image
    JotForm Support

    Answered by Charlie on February 11, 2015 at 08:26 AM

    Hi,

    It seems that the form is actually written originally in Espanol, you will need to edit the whole form in English before you can translate it to other languages. You need to edit the labels and name of the fields to English, after that add the other language you would like.

    To fix this, you can first try removing the other languages and leave the English one, after that edit your field names and labels to English as default, after that add the other languages and if some needs translations you can manually add them.

    I hope this helps. Do let us know if this works.

    Thank you.

  • Profile Image

    Answered by Colorapps on February 12, 2015 at 04:20 PM

    Hello,

    I have done the steps you suggested but it doesn't work. I have removed all langues except English and I have change all names and labels to English, but when I add Spanish again I can't translate them. The translation tool doesn't open for spanish. On the other hand, if I try to add another language, the translation page appears automatically but the tranlations aren't show on the previewed form.

    May i change the html text also? And the options from the selects? I would like to avoid redo all the form again...

    Thank you.

  • Profile Image

    Answered by Sean on February 12, 2015 at 06:02 PM

    I tested your form and I was able to replicate the issue. There is no response on the form when a different language is selected. I will clone your form and do some test to see if I can resolve the issue for you. I will post an update on this thread later on today.

    Cheers!

  • Profile Image

    Answered by Sean on February 13, 2015 at 11:13 PM

    Hello Colorapps,,

    I cloned your form and made some adjustments. It appears that most - if not all - your fields were not converted back into English so the translation was not functioning as it should. I have gone ahead and translate everything on your form to English and I added Espanol to the language list. It seems to be functioning just fine base on my checks.

    Here is my cloned version of your form:
    http://form.jotformpro.com/form/50438589188975?

    You can carry out your test on this form to confirm if it is functioning exactly how you would want it to. Feel free to point on any adjustments that needs to be made and I will have it address. If you wish to clone my version of the form please follow this guide. Do let us know if further assistance is needed.


    Cheers!

  • Profile Image

    Answered by Colorapps on February 18, 2015 at 10:18 AM

    Hello!

     

    thanks so much for your help and effort. I am gonna try your improvements and I'll text you back!

     

    Cheers!

  • Profile Image
    JotForm Support

    Answered by Charlie on February 18, 2015 at 11:31 AM

    You're welcome, please do let us know if the edited form of my colleague works. We'll wait for your response.

    Kind regards.

  • Profile Image

    Answered by Colorapps on February 18, 2015 at 11:36 AM

    Hi again,

    I have been testing the changes you made in our form, and something is still wrong. Now I can translate some the fields with the translator tool, but other translations aren't correctly saved. furthermore, some of the saved ones, when I add a new translation in other field, they lose the translation.

    I think something is messing everything with the translations..

     

  • Profile Image

    Answered by Colorapps on February 18, 2015 at 11:37 AM

    By the way let me know if you need more details!

  • Profile Image

    Answered by Sean on February 18, 2015 at 12:46 PM

    I tried the form once more and I was able to replicate this. It appears that there is bug with the translation for Text fields and some of the check boxes as you mentioned. I have updated your opened ticket with your new findings. Our development team will be looking into this issue also. Once again, sorry for the inconvenience caused and we will get this issue resolved for you. Your patience is really appreciated. We will be in touch.


    Cheers!

  • Profile Image

    Answered by Colorapps on February 26, 2015 at 03:29 AM

    Hello,

    did you finally found something that could solve the issues?

    Thanks!

     

  • Profile Image
    JotForm Support

    Answered by Charlie on February 26, 2015 at 08:26 AM

    Hi,

    Unfortunately, the ticket status for this bug is still open, but someone is already working on it. We'll hear from them when a fix has been made. I also tried cloning my colleagues form, you can check it here: http://form.jotformpro.com/form/50563101070944?. I was able to translate the headings and were saved properly.

    Could you try this, when you translate fields, make sure to translate them one by one. Let's say I want to translate "Personal Information", I translated it to "Información Personal" I then click the first save button, then click the consecutive "save" buttons. In short, try translating them one by one at the same time saving each change up until the last save button. I hope that's clear.

    Thank you.