What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form doesn't show me the revision is choose in Form Revision History

    Asked by jmkinsman on February 09, 2015 at 05:55 AM
    Even though it was not something that I changed (unless it was consequently modified by another change I made) I thought I'd try the revision history suggestion. Now I am experiencing yet another issue in all browsers. When I went in to the revisions. I chose the one from 3:40pm yesterday and thought I would work backwards until the background started showing up in the editor again and go from there. However, once I choose the version, it updates to preview that version, I click ok, it says the it has reverted successfully and I click the X to go to the form (that should now be in the chosen revision state) I am taken to the forms list, I choose the form and click edit and am taken to exactly where the form was, not the revision state. I have tried numerous states on all browsers and no luck. Now I cannot even go back to a different state...

    I have checked the forum for this revision issue. Found 2 threads. One person's updated hours later on its own...? And the other got fixed. Please please please tell me all my work is not lost! Thanks in advance! Really appreciate it!

    revision history revision tool form history form revision restore form
  • Profile Image
    JotForm Support

    Answered by Welvin on February 09, 2015 at 06:07 AM

    Hi,

    I assumed the form is the same, this one http://www.jotform.us/form/50368991292162? Is that correct? Please confirm. If not, include the form URL here so we can check.

    Please note that revisions are logged every 10 minutes of making changes to the form. Also, you should be able to check what are the changes made to the form in the right-hand side of the revision history window:

    Thanks

  • Profile Image

    Answered by jmkinsman on February 11, 2015 at 02:09 PM

    yes, it is the same form. that is why it was included with the other 3 issues with that form before it was moved. Again, I do not feel like you read my question...as with my original issue.

    I understand how revisions work and how to find them and how to see what changes were made in each revision. My issue, as stated above, is that it says that it has successfully reverted to that state and when I try to go to it, the form that shows up in the editor has not been updated to that state, and is instead the state that I was already in.

    So, in the revision area, I choose the state that I want, and when I click the X to go back to the editor, choose the form to edit and click edit, I am taken to the form in the current state that i was just working in, not the chosen revision state.

    Does this make sense? It seems by your response that you think I do not understand how to see what changes were made in that particular revision which is not the issue at all

  • Profile Image

    Answered by Shadae on February 11, 2015 at 03:17 PM

    Hi jmkinsman,

    Once the form has been reverted successfully, you should be redirected to your "My Forms" page.

    If you are not re-directed to your My Forms page, and are still seeing the option the "X" off the revision history, this may mean that it was not successful reverted.

    Please try to Revert Your Form once again

    Then wait for the success message to show

    If you are still having an issue, please sign out of your account, Clear Your Browser's Cache and sign in once again.

    I hope this helps, please inform us if you need further assistance.

  • Profile Image

    Answered by jmkinsman on February 11, 2015 at 03:31 PM

    Hi Shadae,

    As I said "I choose the version, it updates to preview that version, I click ok, it says the it has reverted successfully and I click the X to go to the form" at which point when I choose the form, it is not at the state that it just told me it successfully reverted to. So I already did exactly as you suggest. I need a new suggestion or fix...

    screenshot that was not included in the new thread:

    When Welvin created this new thread, he did not include the part of my message where I said that I already tried clearing cache, clearing history, restarting browsers and restarting the computer with no luck.

    So, any other ideas given that I've already done everything suggested?

  • Profile Image

    Answered by Ben on February 11, 2015 at 04:19 PM

    OK.

    Based on your responses, you are actually following the steps correctly and know your way around JotForm, which is great. We hope that you understand that we had to check if you did all the steps and got the black screen as my colleague Shadae added:

    Now as that is out of the way, please let us know to which date and time you have tried to revert the jotform so that we can try to revert it to that day ourselves and see if the issue is still present.

    This will allow us to capture any errors that are sneaking in the background not allowing you to revert back and ultimately resolve them for you :)

    Thank you for your patience and going with us through all the steps needed.